Stuck in programming mode

Earlier tonight I was downloading a new version of our code to the RC while one of my team mates turned off the robot in mid d/l. The back up battery kept the programming downloading for a few seconds, but when that turned off, the RC did. Now when I turned it back on, the RC seems to be stuck in programming mode. I’ve tried d/l the firm ware back on, but it would not d/l. I’ve tired resetting it, I’ve tired holding downboth program mode and reset and then letting go of reset until it turns green and then hitting reset again. Nothing has worked.

Does anyone know how to fix this??

This is almost the same as a code violation… it isn’t something wrong with your hardware, but check your program for recent changes and remove them one by one to find out what was causing the problem. I hope I pushed you in the right direction at least…

Just so that we’re on the same page:

We do realize that zapping power during code download is not the world’s wisest thing to do, right? (yes – even with the protection that our controller offers).

You could try reloading the MASTER CODE, which may provide a fuller reset than just user code.

Yes, reload the master code, Ive had to do that a couple times with our RC. Is it really in program mode? (program state and rc mode orange/yellow, the rest green) or are just the first two leds lit? That was what happened last time. I had to reload the master code.

Good Luck

We got fixed by holding the programming button throughout the d/l.

We had the same problem, too. Some things that worked were holding down the PROG button for a long time, which would result in some waterfall effect of the LEDs before the RC reset itself. I also found that holding PROG for the normal amount of time would allow me to redownload the code.