not working for me?

Hello, I have been trying to log in on to get the software and it lets me log on but it just leaves me at a white screen.

I have tried everything I can think of but I am unable to download anything because I need to be logged in.

I have tried on:

Ubuntu 9.10 - Firefox, Chrome
Ubuntu 10.04 - Firefox
Windows 7 - Firefox, Chrome, Internet Explorer
Windows XP - Internet Explorer

All to the same effect.

Does anyone have any advice?

Have you tried from a different computer on a different network? Is it possible some schools or businesses have security software that is interfering with access?

I have tried on my home computer (Ubuntu 9.10 && Windows 7) and on my school’s computers (Windows XP).

It worked fine for me just now. Maybe try a different network to change the firewall and such.

I solved the problem by creating a new account…wierd.

Autodesk seems to have been messing around with the logon system; it didn’t work for me a couple days ago, and now it sort-of-works.

I tried to create an account and it failed as my email address is a home address and I’m not a teacher, just a mentor.

Then I sent a teacher’s email address to get invited. Autodesk invited me as a student. I then tried to create an account but was told my email was already in. Now I get to a screen to download code at But when I select a version it goes to a screen with no download button. If I select download center it goes back to select a version screen.

My last year’s account when I registered with them and ended up not downloading the code for trying it is still there with the same email address.

After trying for 1 week I’m about to give up as the build season is 1/6th over. It would really help to have a copy of the software so that I had evenings to work with it and learn how to input stuff. Let alone move it around or actually get anything made.

Its a nice donation, but not if it doesn’t work.

I finally got the download to work by switching from Firefox to IE. When I selected the version of Inventor in Firefox I got nada. In IE it starts to download. Hope that helps as it took me a while to finally give up on Firefox.

After installing Autodesk Firefox was deleted from my Taskbar and replaced with Chrome? I swear I’m missing other Taskbar icons too though I can’t remember what they were. Doesn’t seem to be real PROFESIONAL of them to delete and add items to my taskbar. I don’t like that as I wonder what other changes they have made to my system. I hope I don’t regret the decision to try this.