Talon SRX Breakout Board with Hall Effect Encoders

We’re trying to use the Talon SRX breakout board (http://www.andymark.com/product-p/am-3281.htm) with the Talon SRX controllers and the PG71 motor. The motor comes with hall effect encoder (am-2816a) attached to the back. We connected encoder pins on the breakout board to the encoder, but are unable to read any encoder values. When printing the values in SmartDashboard, they always stay 0. We’re not sure if it’s a wiring issue or programming issue.

Here’s some pictures for how we’re connecting:
https://goo.gl/photos/6gmekW3FFhZBhXi56 (pins on breakout board)
https://goo.gl/photos/XQJWmhJqSngsGHaw5 (encoder)

Wiring question:
The breakout board has 5 pins for encoder (Ch B, V+, Ch A, IDX, V-), whereas the encoder has 4 pins (Ch B, Ch A, VCC, GND). How should those be connected?

Programming question:
We wrote a simple program with 2 CANTalon objects, and one motor following the other. We didn’t yet set the PID values, hoping to just test with the encoder values. But we were not getting any values from the encoder. The code is here: https://github.com/FRC4913/Chell/blob/new-arm/src/org/usfirst/frc/team4913/robot/Arm.java

(x-posted to programming)

I believe your wiring is wrong, you have V+ going to pin one, V- to two, A to three, and B to four when it should be B to one, V+ to pin two, A to three, skip pin 4, and V- to pin 5.

This is how connected them:

Breakout Board ------- Encoder (pins from right)
Pin 1 (CH B) ------- Pin 4 (CH B)
Pin 2 (V+) ------- Pin 1 (VCC)
Pin 3 (CH A) ------- Pin 3 (CH A)
Pin 4 (Index) ------- Pin 2 (GND)
Pin 5 (V-) ------- Not connected

The pin labels on the encoder are not easy to see but here’s the andymark page (http://www.andymark.com/product-p/am-2816a.htm).

We also tried leaving the Pin 2 (GND) of encoder out, but that didn’t change anything.

Have you tried connecting GND to V-?

This is not going to work. Leave the Index floating and connect GND to V-.

Thank you, that worked.

You’re welcome! Happy to help!