talon srx calibration failing

When we try to calibrate our drive train talon srxes it always fails. By fails I mean we get red blinking leds instead of green after releasing B/C CAL button. Tried using joystick to apply signal and smart dashboard with robot in test mode.
We are following the instructions in talon srx user guide. FW is updated(to 2.0 i’m told by students). Talons seems to work fine otherwise, motors operate fine on all subsystems. This happens with any talon we try on our robot. So I’m thinking we are just doing something wrong… but can’t figure out what. Anyone have ideas?
Thanks.
-Maciej

Try running in Teleop mode instead.

(and have the robot up on blocks just in case)

We have tried teleop mode with joysticks and test mode with smartdashboard.

Are the talons wired for CAN or PWM control?

CAN

Double check that they all have unique CAN IDs through the roboRIO web browser.
ID each one using the identify button in the browser.

They all have unique IDs. We see no faults using the talon web browser thingy.

PWM Calibration calibrates the “min” and “max” PWM signal. See section 2.2 in the Talon SRX User’s Guide.

PWM Calibration doesn’t use CANbus signals to calibrate, that’s why it fails.

And PWM Calibration doesn’t change the CANbus-user-experience, so you don’t need to perform PWM-Calibration if you are using CANbus.

Thank you… first year we are using canbus. We are just following our regular procedures we have done in past and didn’t read the docs well enough.