Talon SRX controllers are acting funny

Recently, our team wired up a board with a few talon SRX’s (using CAN) to test a few encoders, though they aren’t working exactly right. I tried a few different configurations of motor controllers and recorded the results:

RoboRIO - PDP: PDP light is red, doesn’t connect

RoboRIO- Motor Controller A - PDP: MCA light alternates red, PDP light is orange, and the PDP shows up in the web based config

RoboRIO- MCB - PDP: MCB works, PDP light is red and doesn’t show up in config

RoboRIO- MCB(CAN wiring reversed) - PDP: MCB alternates orange and PDP flashes orange, but neither show up in the web config

RIO-MCA-MCB(original CAN wiring)-PDP: MCB works and shows up, MCA alternates red and PDP flashes red (neither show up).

RIO-MCA-MCB(reversed CAN)-PDP: MCB and the PDP both work, though MCA still alternates red.

RIO-MCB(original CAN) - MCA - PDP: both MCB and PDP are orange, but neither show up in config; MCA is red.

RIO-MCB(reversed) - MCA - PDP: both MCB and PDP work, MCA is red.

Even though it shouldn’t matter what direction the CAN wiring is in, it somehow does. Also, MCB and the PDP shouldn’t be affected by MCA (but of course they are). Additionally, order shouldn’t matter, but it affects the motor controllers.

If RoboRio-PDP is bad I would check three things:

  • terminators on the RoboRIO and the PDP. Make sure they are on for both devices.
  • try different wire/verify continuity/reseat connections
  • verify RoboRIO has latest firmware and image.

What exactly do you mean it shouldn’t matter what direction the can wiring is in? If you mean it doesn’t matter if you connect green-green and yellow-yellow, I’m pretty sure you’re wrong.

Anyways, direct connection from the RoboRIO to the PDP really should work. Maybe you have a bad termination resistor. Power everything off and disconnect everything, and do a resistance check between green-yellow on the RoboRIO and the PDP. You should get 120 ohms in both locations.

No, I’m not switching green and yellow. By reversed, I mean that the SRX has 2 pairs of CAN wires. The first time, one pair was connected to the RIO and other pair was connected to the PDP. Reversed means the wire originally connected to the PDP is now connected to the RIO and vice-versa.

Both terminators are 120 ohms
The Roborio has the latest image

I swapped out fresh CAN wire and RIO-PDP works. I’ll test the other components.

Alright, I’m pretty sure that MC1 is genuinely dead (any way I can verify for sure?), and MC2 just has some bad powerpole connectors. Thanks for your help.

What are the Talon SRX LEDs doing? The Talon SRX User’s Guide Section 2.3 Blink codes can be used to interpret the LEDs.

Omar,

What does it mean when one LED is blinking green, while the other is alternating green/red ?

That sounds like the Talon is in forward (green), but is occasionally seeing a bad can frame, in which case I expect it to be intermittent. Maybe send a video to support@crosstheroadelectronics.com?

CAN error frames will blurp red on the LED pattern to let you know something is wrong.

Done.

CAN error frames will blurp red on the LED pattern to let you know something is wrong.

When they blurp red, do they blurp on one LED only, or always on both LEDs?

Just curious…you mean you put the terminator in the ON position on the PDP and measured that to be 120Ohms. You also measured the RoboRIO to be 120Ohms.

Right?

You did not put 2 extra resistors on the CAN wires with the RoboRIO and the PDP?

I ask because I have seen people make a mistake like this.

Correct

What are the Talon SRX LEDs doing?

MC2 alternates yellow when it’s disabled, like it’s supposed to. When it’s run, the light changes color/blinking with speed (and it drives a motor just fine).
MC1 slternates red, so it’s either not connecting or their is a fault. Not connected doesn’t make sense because the CAN signal can pass through it. So I’m assuming there’s something wrong with MC1 itself.

Hello,
I am from team 1389 and we kind of ran into the same sort of problem. We had trouble getting all of the Talon’s configured when they were wired up in CAN. What we found that worked was that when we would restart the roboRio everything, including the PDP, would blink correctly. I don’t know if this is any help but I think it might be worth a try.

One other thought is to try reversing the yellow/green pair on the suspect Talon. Maybe the Talon has the wires internally placed in reverse, meaning the yellow-is-actually-green-and-vice-versa. That could explain why everything works except that one Talon.

Otherwise just contact support@crosstheroadelectronics.com