Talon srx leader not leading on left side

The problem:
our robot has 4 talon srx’s connected to motors in two gearboxes so that two motors turn the right wheels and two turns the left wheels. We put the talons in groups of one leader and one follower when the right leader moves the left leader moves but when the left leader moves the right leader does nothing.
the right side also sometimes has this problem but disconecting and reconecting the batter seams to fix that

What we have tried:
we have tried assigning the various talons to be followers or leaders and whatever we assign to flow the one we assigned to be the left leader outputs 0v. We tried rewiring different talons to different motors and have eliminated there being a problem with our motors. we cleared sticky falts and checked that our CAN BUS is working properly. We check to make sure that our code for the right and left sides are the same.

  1. Do this for each motor one a time to confirm the platform is sound.
    https://phoenix-documentation.readthedocs.io/en/latest/ch13_MC.html

  2. Use Tuner’s blink command to confirm each ID of each physical controller.

  3. Next pull this example down. Update the motor controller types and IDs. Remove the fifth and sixth controller since you have 4 talons.
    https://github.com/CrossTheRoadElec/Phoenix-Examples-Languages/blob/master/Java/SixTalonArcadeDrive/src/main/java/frc/robot/Robot.java

I don’t know what a tuner is for the talon, and we are running in c++. We can confirm that all the IDs are set up correctly for each of the talons, and each of the talons are capable of running correctly. When we run the self test on the talons in the roborio web interface, they all fail the test with the error message:

The self test failed.

SelFeedback0:9:SensorSum|Pos:5896287u Vel:-13881u/100ms

SelFeedback1:6:|Pos:47170296u Vel:-23780u/100ms

PID0 err: 0 iaccum:0 derr:0

PID1 err: 0 iaccum:0 derr:0

Quad/MagEnc(rel)

Pos:5896287u Vel:-55524u/100ms

Pins: A=1 B=1 Id=1 IdEdges:0

Analog Input Pos:-3768848u Vel:78544u/100ms|ADC:958|3.0 V

PulseWidth/MagEnc(abs) Per(us):105790.7

TachVel: 967 u/100ms | 567.00 RPM

PosEncPulse Pos:5896287u Vel:13397u/100ms

ZeroPosOn Idx=Off LimF=On LimR=On

Curr(A):83.25 | Bus(V):4.69 | Temp©:76

Nominal %:0,0

Peak %:0,0

Closed Loop AllowedErr:Slot0=0,Slot1=0

Vel Sampling Per(ms):0,AvgWin:0

VCompSat:0.0

R2 : Didn’t receive any status frames.

Make sure device is powered and STATUS LED is not red(blink 1Hz).

If STATUS LED is red(blink 1Hz) then CAN is not functioning.

Common causes…

-Termination Resistor is not enabled in PDP or PDP is not at the end of the chain.

-CANH(yellow) or CANL(green) is disconnected.

-Device has no firmware. If STATUS LED is blinking green/orange, it needs to be field-upgraded.

The STATUS LED is not blinking red, it is blinking orange, which according to the documentation means it is in break mode. We couldn’t find anything about the error message “Didn’t receive any status frames.” on the internet.

FYI, sounds like you haven’t updated to the 2019 software yet.

Where would we find that? I don’t see anything on the FRC resource page.

Good question…
Start here => https://www.firstinspires.org/robotics/frc
Somehow get to => https://www.firstinspires.org/resource-library/frc/electrical-and-software-resources
Click on control sys link to get to screensteps
Find third party section
FRC => https://wpilib.screenstepslive.com/s/currentCS/m/getting_started/l/682619-3rd-party-libraries
Click on CTRE
CTRE => http://www.ctr-electronics.com/control-system/hro.html#product_tabs_technical_resources
Which has the installer and doc link
Software Documentation => https://phoenix-documentation.readthedocs.io/en/latest/index.html
Start at the top and work your way down.

I just tell people to go to our site (we put ctr-electronics.com on every FRC product we make), then go to its product page for support. Once you get to our site, its smoother since we support our products directly.