TalonFX Config Peak Output Reverse

Ever since I updated to the 2022 firmware for the TalonFX the peak reverse output has been permanently set to 0. I’ve tried setting it in code, I’ve tried setting it in the phoenix tuner. I’d guess it was a firmware bug if not for the fact that no one else online seems to have this glaring problem.

I would rule out the robot application by deploying the temporary diagnostic server, then factory-defaulting the Talon FX in the config tab. If that works I would then bring the robot application back in and figuring out what’s going on in there, maybe it’s constantly being configured in a periodic loop or something.
Also a note, the peak reverse output is a range [-1, 0], which sometimes people get bit by when they try to configure it to +1, and it truncates to 0.

Ok I got the motor to move backward by setting the peak reverse output through the phoenix tuner

but whenever I try to set the peak output to anything with code it just gets set to 0

1 Like

ok appearently the class WPI_TalonFX doesn’t have this problem while TalonFX does

I just attempted to reproduce this with a TalonFX I’ve got on hand.
For both TalonFX and WPI_TalonFX in both Java and C++, configPeakOutputReverse works as expected, verified by looking at the values in Phoenix Tuner, and ensuring they change on robot application deploy to the value I configured in code.

I would zoom into any other changes that may have happened between the WPI_TalonFX and normal TalonFX change, and double check how you’re verifying the config is what it is.