Talons Not Responding...? Help...!

I have been trying to code two Talon SRX motor controllers to run one direction when a button is pressed. However, when I am enabling our robot the Talons blink orange and do not confirm they are receiving code. Am I doing something wrong here? Any help is greatly appreciated!

I would first make sure that they have the ID that you expected them to have. Check your phoenix tuner and check their id numbers(Make sure you are checking the id number not the name because the name might have different number from the actua id).

yep, all device IDs are correct. I’ve even tested them through the tuner itself (I’m not sure if that makes a difference.)

So I’m not a labview programmer but did you guys initialize your joystick? Not shown in the picture and i’m just trying to make sure.

Not helpful to the question, but instead of manually inverting a motor and running it seperately, you can make the TalonSet 2 follow TalonSet 1 so you only have to set TalonSet 1. You can also make it follow it but in the opposite direction.

Have you tried probing the wires in your code? That is an easy way to verify that the button press command is getting to your selector statements.

I probed the button wires and I get a false result even with my joysticks connected and the button pressed. However, I’m not sure how to fix that. :worried:

Could the joystick be in the wrong position on the Driver Station USB tab?

The blinking yellow status on the Talons after the robot is Enabled by the Driver Station is concerning of course.
Since that means the code and Talons are not connecting.

You’d probably need to post at least the complete Begin and Teleop vi’s if you want help looking for bugs.
What you showed is fine,

If the talons are still blinking orange, then they are not recognizing the bot as being Enabled (solid orange) - check wiring, check the driver station for erros about CAN IDs - code looks code (assuming you want to press button #2)

Here is what I have at the moment. I tried to use the same method I used for the Victor SPX controllers, which all work okay.

Can you zip the whole project folder for us?
Documents->LabVIEW Data->project

We can run the project to see if we have the same issues.

robo2020.zip (22 Bytes)

Thank you for the help!

When you enable the robot, are there any errors in the driver station?

I’d expect to see at least some complaints about the lack of CAN IDs being found.

The joysticks are a problem. But, they’re only a problem once you figure out how to get the blinking lights on the Talons to stop. Until that point, the joysticks can be perfect but you won’t make progress because the Talons aren’t getting the signals.

The zip is empty

Someone may have already said some of these, but just in case…

  1. Make certain that the firmware on the motor controllers has the latest update. (Use the CTRE software tool.)
  2. Make certain that the motor controllers have the desired CAN IDs and that these IDs are not duplicated on your CAN bus.
  3. Make certain that you are using the set of Open VI for your model of motor controller. The Talon SRX and Victor SPX use different VIs.
  4. Use the driver station to double check that you are using the button you think you are using. There is a tab that shows which button is being pressed.
  5. Write things to the dashboard so you can see what you are trying to do.
  6. Make certain that the Set and Get reference VI use exactly the same strings. This includes checking for capitals, embedded spaces, and especially trailing spaces!
  7. If using CAN based motor controllers, you may need to use the SET VI for those motor controllers. (I think that this might have been a problem in past years. Likely someone else has more experience about this particular thing.)

Here is a quick sample drive code (not tested…)
In BEGIN.VI
image

In Teleop

I have no error codes in the drive station.

robo2020.zip (7.8 KB)

sorry, try this one?

That’s now a single file, not the whole project folder.
zip this entire folder Documents->LabVIEW Data->robo2020

The whole directory of files for a LabVIEW project look like this:
If it doesn’t have these files then there is a different (easier to solve) problem.


The whole master folder will let us test run your project.

2020 Robot Proj.zip (2.4 MB)

Sorry for the late reply. My computer had crashed and I lost all my progress, so I made a new code and tried to double-check it.