Team 996 in need of help

This year, our team is very scrapped for members. So I have volunteered for programming. The problem? I am a freshman, and this is my first year at doing anything related to robotics. I found a skeleton program in LabVIEW, like a starter program, to try to get the hang of it. Our problem is that it is not working, and since I am new at this, failure analysis is almost nonexistent. All our hardware is correctly set up,(that is something we know how to do), and everything is communicating properly. I’m even getting readings from the joysticks on the driver station. But when I move our joysticks, nothing happens. I used this PDF - - to try to get a handle on things. I followed it exactly, and things still aren’t working.

Can anyone tell me what might be going wrong? Thanks!

I am a (fairly) new mentor with a little LabVIEW experience.

We had trouble getting a tethered setup to work with our computer. But if we did a “startup” deployment of the project and rebooted the cRIO, everything worked fine.


  1. did you “image” the cRIO?
  2. Have you “Run” your while connected to the robot with an ethernet cable?
  3. Have you looked at the documentation under Turorial when you start up LabVIEW? I found those guides MUCH better than the condensed FRC pdfs.

If your answer is “No” to those, try them! For the Tutorial, open LabVIEW, click Tutorials, and then “Turorial 4: Developing a Robot Project”

In addition, I strongly suggest you go to and watch the videos. They are slightly out of date, but they are a valuable resource for learning how to program an fRC robot in labview.

Also, if you have the default code loaded in, and everything looks like it should be working, it could be the DB37 cable. Have you done the rework of it as shown here?

I re wired the DB37 cable, and my code is still not working. I ran the ‘Robot’ as a backup check, and even that isn’t working. I am starting to enter panic mode. I have one motor wired to the PWM 1, and another to PWM2. I have each joystick set to a different USB, and have those programmed to each motor. I basically followed the tutorial exactly, and it still isn’t running. I have my IP addresses set correctly, I have the code running, and I have the hardware set up correctly. I don’t know what is wrong!

Couple of checks…

  1. You used a crossover cable to image the cRIO, but are you using the regular ethernet to deploy code?
  2. …are you clicking “Enable” in the driver station?
  3. Are you running the driver station software in a regular windows session, or logging in as “Driver”? I found that the “Driver” login doesn’t work.

Maybe you could post your code,, as an attachment and someone (me, and others) can take a look at it.

I went through all the wiring and scrapped my software. I just decided to go with the ‘Robot’ what was provided. I found the problem in the hardware, (the DB37 cable), and fixed it. Our robot drives now. I was wondering if anybody knew how to change the drive from arcade to tank? We have 2 PWM channels, each spliced into their own Jag, so 4 Jaguars total, 2 Jag’s per side. We are set up in tank drive mechanically, so Arcade is relatively new to us. I would like to be able to switch the setup in the ‘’ of the ‘Robot’ to tank mode. Is there any way to do this simply? Or is it an entire ordeal?


To switch from arcade to tank drive in LabView,

  1. Define your second joystick in the Begin vi.
  2. Open the teleop vi in Robot Main.
  3. Add code to read the second joystick using the Joystick 1 code as an example
  4. Replace the Arcade Drive vi with the Tank Drive vi. The Arcade Drive and Tank Drive vi’s are in the WPI Robotics Library->Robot path of the Functions Palate.
  5. Connect the X or Y wire from Joystick 1 to the Tank Drive vi and the X or Y wire from Joystick 2 to the Tank Drive vi.

I hope that helps.

It does, thanks!