The download it does nothing

I was pleasantly surprised this year to find that WindRiver (seems to) be working properly. I have some problems that might/might not be related to Wind River.

The sample projects and my alterations compile :slight_smile: and the FRC downloader seems properly configured with team number & .out file. When I use download it seems to finish successfully. But when I reset the robot, the code hasn’t changed. Any idea why it would do that?

I have also properly configured the camera and connected it to the cRIO but the little yellow light on the Ethernet port does not blink and nothing shows up on-screen. Does the robot code need to activate the camera somehow? If so, the previous problem would keep me from finding out. I know almost nothing about the camera and my teammates want it to align the robot for this year’s game ::ouch::

Also, why does the Camera to dashboard example not produce a .out file?

I have some of these same problems, although I cannot debug anything either. But some builds don’t produce a .out file and the FIRST downloader does nothing. I am going to try a different computer soon

It took me a very very long time and the setup seems to be very fragile, at least to me. For like the first couple hours of hair-pulling, I realized that it was “Downloading To” a localhost connection that you can see in the lower-left corner. I honestly can’t recall what fixed it but your first try may be to remove that localhost connection and only have the robot connection. I will try to look in to it more.

I deleted the Local Host but it didn’t fix the problem. I did some more work today that seemed to confirm the download wasn’t working. I tried to use the Run and Debug configurations, but they terminated instantly and the Robot Code light turned red. Interestingly, when I ran the debugger for one project it stopped in a different one :ahh:

I agree, the setup is very fragile. Why is it that every year I have to jump through dozens of hoops just to get this thing to work? Is this some sort of plot by the GDC?

Did you set up the Remote System as per the C programming Manual?

Make sure you are downloading the correct *.out file - if you are downloading the same (wrong) one, the symptom will be that the code never changes.

Please see and scroll down to “But, we’re not done” to be sure you are getting the correct file.

It was worth a check. Yes, the file path is correct.

Run still does nothing.

I re-imaged the cRIO again and it has no robot code. Let’s see if I can change that.

I used the C:/windriver workspace with only one project and it works. Auto-completion also started working. Before, I was using a workspace on the D:/ drive.

Run/Debug still halt instantly. Here’s the trace from the Console Out:

Break at 0x0219d2c4: FRC_UserProgram_StartupLibraryInit   Task: 0x2217cf8 (tFRC_
WPILib was compiled from SVN revision 2069
task 0x218a5c0 (FRC_DriverStation) deleted: errno=0 (0) status=0 (0)
task 0x1d62d08 (FRC_RobotTask) deleted: errno=0 (0) status=0 (0)
!!!   Error: Default code was still running... It was unloaded for you... Please
 try again.
task 0x2217cf8 (tFRC_UserProgram_StartupLibraryInit) deleted: errno=0 (0) status
=0 (0)

Using “Undeploy” first did nothing. What’s going on?

Error: Default code was still running… It was unloaded for you… Please
try again

Did you reboot? there is code running, but you need to reboot between sessions