The RoboRIO is suddenly not accepting/running code

We get the following log when trying to build code:

Buildfile: C:\Users\Programmer\workspace\Robot-Code\build.xml
Trying to override old definition of task classloader
   [delete] Deleting directory C:\Users\Programmer\workspace\Robot-Code\build
   [delete] Deleting directory C:\Users\Programmer\workspace\Robot-Code\dist
    [mkdir] Created dir: C:\Users\Programmer\workspace\Robot-Code\build
     [echo] [athena-compile] Compiling src with classpath=C:\Users\Programmer/wpilib/java/current/lib/WPILib.jar:C:\Users\Programmer/wpilib/java/current/lib/NetworkTables.jar to build
    [javac] Compiling 8 source files to C:\Users\Programmer\workspace\Robot-Code\build
     [echo] [athena-jar] Making jar dist/FRCUserProgram.jar.
    [mkdir] Created dir: C:\Users\Programmer\workspace\Robot-Code\dist
    [mkdir] Created dir: C:\Users\Programmer\workspace\Robot-Code\build\jars
     [echo] [athena-jar] Copying jars from C:\Users\Programmer/wpilib/java/current/lib/WPILib.jar:C:\Users\Programmer/wpilib/java/current/lib/NetworkTables.jar to build/jars.
     [copy] Copying 2 files to C:\Users\Programmer\workspace\Robot-Code\build\jars
      [jar] Building jar: C:\Users\Programmer\workspace\Robot-Code\dist\FRCUserProgram.jar
     [echo] Trying Target: roboRIO-3617.local
     [echo] roboRIO found via mDNS
     [echo] roboRIO image version validated
     [echo] Checking for JRE. If this fails install the JRE using these instructions:
  [sshexec] Connecting to roboRIO-3617.local:22
  [sshexec] cmd : test -d /usr/local/frc/JRE
     [echo] [athena-deploy] Copying code over.
      [scp] Connecting to roboRIO-3617.local:22
      [scp] done.
  [sshexec] Connecting to roboRIO-3617.local:22
  [sshexec] cmd : killall netconsole-host
  [sshexec] killall: netconsole-host: no process killed
  [sshexec] Remote command failed with exit status 1
      [scp] Connecting to roboRIO-3617.local:22
      [scp] done.
      [scp] Connecting to roboRIO-3617.local:22
      [scp] done.
     [echo] [athena-deploy] Starting program.
  [sshexec] Connecting to roboRIO-3617.local:22
  [sshexec] cmd : . /etc/profile.d/; /usr/local/frc/bin/ -t -r;
  [sshexec] start-stop-daemon: warning: killing process 3031: No such process
Total time: 7 seconds

This log has not changed despite reimaging the RoboRIO. We’re getting desperate here. Any ideas?

The code is deploying fine, the problem is likely that your code is crashing. Do you get any message on the Driver Station messages window or in rioLog after deploying?

We also have tried it with the sample code, and with known working code. The RIOLog says

ERROR Unhandled exception instantiating robot edu.cold.logic.Robot java.lang.ExceptionInInitializerError at [java.lang.Class.forName0(Native Method), java.lang.Class.forName(, edu.wpi.first.wpilibj.RobotBase.main(]

There should probably be more lines after that which will tell you what the real error is.

There isn’t. It’s weird but if you get an error in one of your constructors (e.g. a subsystem constructor) it throws this error. Could you post your code here?

My team is also having the same issues with the RoboRio and I was wondering how you solved it, assuming that you have. If you have I would appreciate some advice on how you did so and what the problem ended up being. Thanks in advance.