Too Many Simultaneous Camera Streams

Our camera worked fine in our lab over wireless. However, when connecting via tether (ethernet or USB), we start seeing the error “Too many simultaneous camera streams” repeating in the DS error window and the camera image is more less frozen. Haven’t seen this one before. This happens with at home or field configuration of the radio.

What dashboard is this with (and what version of the dashboard)? The camera server limits the maximum number of simultaneous streams (client connections) to put a cap on resource usage. Potentially the cause of this error is the dashboard opening a connection, thinking there’s an error, and opening another connection while failing to close the previous one, and repeating.

Shuffleboard 2022.3.1 (I’m not in the lab right now but I’m pretty sure that is the right number).

If you didn’t try this, try exiting the dashboard and restarting it.

Ok. Will try that later today at club time.

Ok. Did some testing.

  1. on field config on tether, too many streams error, restart SB and DS does not cure problem. Camera feed very slow as one might expect. After restart takes a bit before error appears.
  2. reconfig radio back to home settings. Too many streams error on tether. Restart SB and DS does not cure problem. Feed is very slow.
  3. connect via WiFi without restarting SB or DS and too many streams error occurred.
  4. Restarted SB and DS (still on WiFi) and the problem went away, feed normal speed.

Forgot to mention than in situation 1 above, SB showed network tables not connected. Never could get network tables to connect while on tether at competition so SB would not work in pit…but worked on the field.

After a lot more testing this appears to be some sort of firewall issue with Windows 10 and the ethernet connection to the robot. WIFI works fine but ethernet will not do the camera feed correctly. The firewall configuration for both interfaces would appear to be the same but there is a clear difference between the two. The issue with network tables was a firewall issue as well, which I corrected and got that working on tether…but the same firewall config worked on WIFI before I modified it to get tether working. Opened ports and allowed Java apps, everything I can think of but something still seems to prevent or interfere with camera on ethernet.

One thing, the both the ethernet and WIFI were incorrectly flagged as Public connections instead of Private. Can’t get Windows to let me change that. And, the WIFI flagged as public works.

Next step is to set up another PC and start from scratch…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.