Toshiba Cardbus Problem?

Hey all, thought I’d throw out a random hardware question with hopes of a quick solution. After I accidentally uninstalled my laptop’s wireless card’s driver I have been unable to reinstall it. I select the correct driver and after it begins copying files it stops with an error reading ‘The system cannot find the specified file.’ At first I thought it was the wireless card but I had the same error come up when I tried a different flavor of wireless card. I’ve tried both slots and reinstalling the cardbus drivers, but neither action had an effect. Ideas? :confused:

the warning from microsoft says ‘file’ that leads me to believe that the file containing the driver is corupted, search the internet for the latest driver download for your wireless card and that should fix your problem.

The fact that two cards wouldn’t install with the same error message suggests to me that the problem is not the driver. I was unable to find better drivers than the ones I’m currently trying.

Maybe, maybe not. I assume your wireless card is plug-and-play, no? Anyway, the subsystem you’re looking to debug is the setupAPI system - when a driver is installed in Windows, it’s actually not installed but “pre-installed” via setupAPI. If you enable setupAPI logging and then view the log file when this error comes up, it might shed some light on the file it’s having a hard time finding.

It is also entirely possible the uninstallation didn’t remove a registry key that the installer uses to determine if the driver is installed (and thus doesn’t install all files because that registry key says the files are already there). In that case you might be SOL if the device depends on other registry keys that are added only by the installer. Find the INF file that refers to your cardbus device (c:\windows\inf) and make sure all the files it refers to are on your system (.sys files in c:\windows\system32\drivers and .dll files in c:\windows\system32).

Good Luck.
-Danny

I have had this problem with two Linksys driver disks in the past. Since the install doesn’t complete, the computer doesn’t realize that some of the driver files are incomplete. Download the latest driver from the manufacturers site and save it to a disk. I found that by going to network properties and removing every service associated with the card allowed me to reinstall the driver from a known good disk. Go to Start, settings, network connections, and llok for any installed connection. (Not network setup wizard or new connection wizard) If there is a connection installed, click on it and a two tab folder should open. At the bottom is a “properties” button. When you clcik on that, a four tab folder opens with the services installed list showing. Click on each one and delete until everything is removed. Then try removing the card and reinstalling so that new hardware wizard will find the card. Use the new disk to install the drivers. Hope that works.

I don’t have any wireless network connections without a working wireless device. I tried the regedit to log the error but (1) I couldn’t figure out what the Add Hardware service name was and (2) I don’t know how to view the log.

Puzzlingly, whenever the card is inserted in the laptop the device manager lists it but says that it is not working properly because the driver is not installed. When I try to delete the device it says that it is required to boot the computer. The device disappears from the list when it’s removed. Thanks for your advice so far. I appreciate the help. :smiley:

That’s actually not a problem - you read too far. Just turn on the logging levels for ALL devices (by setting the HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\LogLevel registry key to 0x0000FFFF), and check the logfile when it pops up and tells you it couldn’t “find a file” - the logfile is called setupapi.log and it sits in your c:\windows directory (if memory serves me correct).

Hmmm, may be the case of a corrupted dev node - I actually ran into a system showing the same symptoms with a scanner this past weekend. I had to reboot the computer with the device not inserted, and then perform the following steps:

  1. Open a command prompt (start->run and type: cmd).
  2. Execute the following command:
    set DEVMGR_SHOW_NONPRESENT_DEVICES=1
  3. Open your device manager, and select View->Show Hidden Devices.
  4. Delete the dev node for your cardbus device.

Be careful, the DEVMGR_SHOW_NONPRESENT_DEVICES environment variable is one that most never have to use (mostly used when developing/debugging a driver). It will show you the “stored” devnode for a device not plugged in - when you plug in a device this devnode is loaded and used (there are some situations where this is not true, but that’s beyond the scope of this exercise). If there’s a problem with the devnode, it might not be possible to delete it with the device plugged in, so you have to cause Windows to show it to you when it’s not plugged in - just the usual “Show hidden devices” doesn’t work because that will just show hidden devices that ARE “plugged in”.

Anyway, after deleting the devnode you should be able to attempt to install the driver again, and this time it will create a new devnode and maybe it will allow the driver to be installed properly.

Good Luck.

-Danny

When it stops during install does it always stop at the same point? the drivers you are using for the different devices are they the windows default drivers or on a CD that came with the card?

Also the cardbus controller my have a corrupted driver, try checking that too.

When you download a driver it doesnt have to be knewer it just needs to have all the files intact, the reason i said get the latest driver was just to kill 2 birds with 1 stone.

Theres a verry easy but annoying solution to this problem. When you go to install the drivers wait for the error message to pop up. then write down the file name thats misssing. Next, do a seach of your computer for that file name, chances are it’s already on your computer under one of the windows folders. So when it asks for the location of the missing file just redirect it to the right windows folder. I get quesions like this all the time on IRC, and most of the time my solution works. you might have to repeat the process a few times as it might need to find more than one file.

Heh, easier said than done. If it’s the same error I think it is, the error message is exactly, “The system cannot find the specified file.” With most of the setupAPI errors you aren’t given nice debuggable prompts, which is why the setupAPI logging exists - the drivers are being loaded in an internal procedure, you’re just not told what the specific calls are that are being made. Many times if a device’s Windows devnode is pointing to a specific driver location, and that location changes (because it’s uninstalled, etc…) without the devnode being deleted or updated, the setupAPI becomes quite confused. Even when you know what you’re doing it’s not always clear how to solve the problem!

-Danny

Here’s how the log reads:

[2005/12/31 08:39:28 592.12 Driver Install]: #-019 Searching for hardware ID(s): pci\ven_104c&dev_9066&subsys_ab8013d1&rev_00,pci\ven_104c&dev_9066&subsys_ab8013d1,pci\ven_104c&dev_9066&cc_028000,pci\ven_104c&dev_9066&cc_0280
[2005/12/31 08:39:28 592.12 Driver Install]: #-018 Searching for compatible ID(s): pci\ven_104c&dev_9066&rev_00,pci\ven_104c&dev_9066,pci\ven_104c&cc_028000,pci\ven_104c&cc_0280,pci\ven_104c,pci\cc_028000,pci\cc_0280
[2005/12/31 08:39:28 592.12 Driver Install]: #-198 Command line processed: C:\WINDOWS\system32\services.exe
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:28.843 #V005 Opened the PNF file of "C:\WINDOWS\inf	net1130.inf" (Language = 0409).
[2005/12/31 08:39:28 592.12 Driver Install]: #I022 Found "PCI\VEN_104C&DEV_9066&SUBSYS_AB8013D1" in C:\WINDOWS\inf	net1130.inf; Device: "802.11g Wireless CardBus PC Card"; Driver: "802.11g Wireless CardBus PC Card"; Provider: "Texas Instruments"; Mfg: "Texas Instruments"; Section name: "TIACXXP".
[2005/12/31 08:39:28 592.12 Driver Install]: #I087 Driver node not trusted, rank changed from 0x00000001 to 0x00008001.
[2005/12/31 08:39:28 592.12 Driver Install]: #I023 Actual install section: [TIACXXP]. Rank: 0x00008001. Effective driver date: 03/10/2004.
[2005/12/31 08:39:28 592.12 Driver Install]: #-147 Loading class installer module for "802.11g Wireless CardBus PC Card".
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:29.173 #V286 Verification using alternate platform (Platform = 2, High Version = 5.1, Low Version = 5.0).
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:29.424 #V132 File "C:\WINDOWS\system32\NetCfgx.dll" (key "NetCfgx.dll") is signed in catalog "C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\sp2.cat".
[2005/12/31 08:39:28 592.12 Driver Install]: #-166 Device install function: DIF_SELECTBESTCOMPATDRV.
[2005/12/31 08:39:28 592.12 Driver Install]: #I063 Selected driver installs from section [TIACXXP] in "c:\windows\inf	net1130.inf".
[2005/12/31 08:39:28 592.12 Driver Install]: #I320 Class GUID of device remains: {4D36E972-E325-11CE-BFC1-08002BE10318}.
[2005/12/31 08:39:28 592.12 Driver Install]: #I060 Set selected driver.
[2005/12/31 08:39:28 592.12 Driver Install]: #I058 Selected best compatible driver.
[2005/12/31 08:39:29 592.13]: #-198 Command line processed: C:\WINDOWS\system32\services.exe
[2005/12/31 08:39:29 592.13]: @ 08:39:29.884 #V005 Opened the PNF file of "c:\windows\inf	net1130.inf" (Language = 0409).
[2005/12/31 08:39:28 592.12 Driver Install]: #-166 Device install function: DIF_ALLOW_INSTALL.
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:29.984 #V005 Opened the PNF file of "c:\windows\inf	net1130.inf" (Language = 0409).
[2005/12/31 08:39:28 592.12 Driver Install]: #-166 Device install function: DIF_INSTALLDEVICEFILES.
[2005/12/31 08:39:28 592.12 Driver Install]: #I124 Doing copy-only install of "PCI\VEN_104C&DEV_9066&SUBSYS_AB8013D1&REV_00\5&8BEE444&1&0020F0".
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:30.826 #V005 Opened the PNF file of "c:\windows\inf	net1130.inf" (Language = 0409).
[2005/12/31 08:39:28 592.12 Driver Install]: #-011 Installing section [TIACXXP] from "c:\windows\inf	net1130.inf".
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:30.926 #V005 Opened the PNF file of "c:\windows\inf	net1130.inf" (Language = 0409).
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:30.986 #V286 Verification using alternate platform (Platform = 2, High Version = 5.1, Low Version = 5.0).
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:31.066 #I180 Verifying file "c:\windows\inf	net1130.inf" (key "tnet1130.inf") against catalog "" failed. Error 1168: Element not found.
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:31.236 #I180 Verifying file "c:\windows\inf	net1130.inf" (key "tnet1130.inf") against catalog "" failed. Error 1168: Element not found.
[2005/12/31 08:39:28 592.12 Driver Install]: @ 08:39:31.296 #E358 An unsigned or incorrectly signed file "c:\windows\inf	net1130.inf" for driver "802.11g Wireless CardBus PC Card" blocked (server install). Error 1168: Element not found.
[2005/12/31 08:39:28 592.12 Driver Install]: #E122 Device install failed. Error 1168: Element not found.
[2005/12/31 08:39:28 592.12 Driver Install]: #E157 Default installer failed. Error 1168: Element not found.

Is this due to what is truly a bad driver file? It’s the only one offered on their site. The card was originally installed with the CD that came with it. I’m still puzzled why the other card would have the same error though. Also, when starting the laptop without the card inserted and viewing the hidden devices, the driver is still un-deletable. It is said to be required to boot the computer.

Thanks again for the ideas. It’s certainly something to keep my brain working between the sleep-inducing holiday meals.

Did u get that error message with the drivers downloaded off the manufacturers site or was that error with your CD if that is the downloaded one then your problem is not a bad driver(what i meant by corrupt is somehow the disk where the driver was being stored got damaged)

Doubtful, looks like something is just amiss in the current configuration of your system. Delete the PNF file - it’s okay to delete PNF files, when the INF file is accessed a new PNF will be generated - it should be “c:\windows\inf net1130.pnf”. Also make sure you’re an Admin when installing the device (I figure this is a duh?).

Hmmm, that might mean there’s a service that is loaded that is refusing the uninstall. Look in the INF file for a .sys file listed as a service and either move, or rename it (don’t delete it, there might be other devices that depend on it) and then reboot.

At this point I’m just guessing at the reason for the problem, something is obviously configured strange and is causing some weirdness above and beyond what I normally see. Unfortunately I have to say the driver is probably good, but the uninstaller didn’t do its job and leave everything as the installer found it. :mad:

-Danny