Tripping breakers on flywheel shooter

We have designed and created a flywheel shooter prototype to test wheel materials, compression, RPMs, etc. We are running into a significant problem. Every time we spin up the flywheel at a reasonably rapid rate, (anything greater than 2.5v/second), it trips a 40amp breaker and shuts down.

The power train currently consists of 2 775 pros geared to a 4" Colson, and an overall gear ratio of
2.4:1 (2.4 rotations of the motor for every rotation of the flywheel). The gearing is achieved through a 4:1 Versaplanetary followed by a 36t:60t pulley. According to JVN Design Calculator, if you model the system as a 2in arm with a weight of 0.76lbs (which I am sure is not the correct way to model the system), the system should only be pulling a maximum of 7.42 amps, which is significantly less than the 40+ amps the system must be pulling. image

Interestingly, I am able to spin up the flywheel without a problem when I set the ramp rate to anything over 5 seconds (ramp rate being input as seconds from neutral to full power, meaning that 5 seconds converts to 2.4volts/second). The problem with this is that I am unable to effectively use a velocity control loop at this ramp rate, since the system isn’t able to accelerate fast enough to maintain an RPM.

Something must be fundamentally wrong in my system, since I know for a fact teams have pulled off significantly more aggressive ratios with far more aggressive ramp rates without a problem in the past. For example, in 2016, according to their 2016 Technical Binder 254 had a 30:19 ratio (1.57:1, far less reduction than our 2.4:1), and according to their code release, they used a ramp rate of 36v/second. In a more recent (and not 254) example, from this year’s Bison Robotics Ri3D shooter with just one 775pro,

I currently don’t have access to our workspace, so I can’t take any pictures, but will be more than happy to post pictures after 3pm. Some things to note:

  • We are using an old PDM (blue PDP) for this prototype
  • The system is being run on TalonSRXs on the last 2019 update
  • We tried powering the system with a brand new battery probed at 13.2v, and a dead battery probed at 11.9v, problem persisted in both scenarios.
  • The belts are tensioned properly, not overly tight or loose.
  • The wheel spins freely and easily by hand when not powered.

I’m losing my mind over here. Any ideas?

2 Likes

The math you’re using all seems correct.

Are the breakers tripping every time you spin up the flywheel, or just when you throw a ball through?
How much flywheel mass do you have? Maybe spinning up a large amount of inertia causes the motors to draw a lot of current.
Are the motors hot when you touch them? Hot motors have higher resistance and lower efficiency than cold ones.
How fast are you able to get your flywheels going before the breaker trips?
Are both motors able to run independently? It could potentially just be one motor taking up all the load.
Also, check again for any mechanical losses in the system, Spin it as fast as you can by hand, and see how long it takes to slow down. Are there any weird noises coming from it?

Intuitively I cannot immediately think of a reason such a setup would trip a breaker. Can you show a graph of current / voltage over time as you try to spin up the system?

You’re sure the VP doesn’t have any binding or friction, debris, etc. in it? This would be a small inefficiency hard to notice just by hand but could have a large effect.

This is going to sound very silly, but are you sure both 775pros are spinning in the same direction? In theory, if one is worn and one is new, they could spin opposite directions and the new motor could overpower the old.

I assume both motors are on separate 40A breakers?

1 Like

This is my top contender for the root cause. Note that if you swap the positive and negative contacts on a brushed DC motor, it swaps its rotation direction.

When the ramp rate is less than 5, the breakers trip before the wheel is even able to get up to speed (before we can put a ball through it). When the ramp rate is greater than 5, it doesn’t trip even when we do put a ball through it.

We tried with just the 4" wheel and adding two 6" colsons to the outside for inertia. Both tripped the breakers. One thing to note is that only one breaker trips at a time, but it isn’t always the same breaker.

I remember touching the motors to check their temperature, but I honestly don’t remember the results.

The flywheel usually gets to about 2500rpm before it trips.

I tested each motor independently, and they both spin it up in the correct direction, but we did a lot of plugging and unplugging so I will run the test again tonight.

@Chris_is_me
I actually went to the extreme to rebuild and clean the versaplanetaries to minimize friction, but I will double check tonight and report back.

Each motor is on its own breaker.

1 Like

Did you do any testing with ramp rate for just one motor driving it instead of two?

I actually never tested spinning the system up with each motor independently, I just ran it for long enough to verify that the motor A) ran, and B) spun in the correct direction.

I will test that tonight and report back.

Have you considered programming a current limit into the Talons?
A 40A current limit should prevent breaker tripping.

I had added a continuous current limit of 40 amps. It continued to trip breakers. I added a peak current limit duration of 100ms. It stopped tripping breakers, but it was unable to get to a speed over about 2200rpm.

However I cannot recall if that was me pressing the wrong button or not. I had a button programmed to send 6v to the flywheel without a closed loop. I will test this again tonight, but I would like to solve the underlying problem since the system shouldn’t be drawing this much current (I think).

I am unsure if the “current limit” feature is dependent on CAN data from the PDP. The PDM we are using doesn’t supply that data, so it is possible this is why the breakers tripped with the 40 amp continuous current limit set.

Is it possible there are some wires that are brought into contact for a split second through vibrations or (although significantly less likely) through arcing?

I could see a loose strand of wire causing intermittent shorts as being the root of this issue.

1 Like

That could be it, as the motors leads are facing and very close to each other, but why would a lower ramp rate mitigate that problem?

That’s really slow. How sure are you they aren’t fighting each other?

Have you tried taking each one out of the loop and going for full spin up?

Do you have a dc current clamp that you can use to independently check your real current flow in stationary/hand-spun*, motor A spinup, b spinup, and a+b spin modes?

(*Why stationary? I’m wondering if you have a case short off one motor)

6 Likes

Sometimes electronics work in ways that make no theoretical sense. It’s always worth triple checking for wiring issues though! We’ve solved more problems than I can count by finding a lose wire or PCB pad.

1 Like

If you’re bringing up your rpm slowly with low torque, you don’t have nearly as much vibration in the system and are not flexing the motors against their mounting bolts - so a small gap wouldn’t have as many reasons to close and arc.

3 Likes

Things I will test around 3:30:

  1. Unplug each motor and attempt to spin up the system with each motor individually.
  2. Place a piece of paper between the motors to verify separation of leads
2 Likes

Is the same breaker tripping each time? Try swapping the motors between controllers and see if it follows the motor or controller. If it stays with the controller swap the controller power feeds.

Only one breaker trips at a time, but it isn’t always the same breaker.

Are the breakers new, or previously used? I’m wondering if you possibly have some defective breakers.

Take a look at the driver station logs - you can see the current output for each branch, which would tell us a lot about how it’s working. Grabbing screenshots of each motor individually and the two motors together could help. Just make sure you zoom in on that particular section so we can see the details :slight_smile:

Unfortunately since we are running the system on an old PDM (blue PDP), it doesn’t have CAN connection, and therefore doesn’t log current. Otherwise you know I would have included them in my original post :wink:

Oh, duh. In that case, I’d swap out to a new PDP to help with diagnosing :smiley:

1 Like