Trouble driving with Talon SRX

We are using the versaplanetary integrated encoder with Talon SRX for our scissor lift motor. We are able to read encoder data to the smart dashboard from the Talon. We also followed the Phoenix documentation closely when setting up the device. Our problem is with running the motors with Talons. We tried using scissorLift.set(ControlMode.Velocity, joystick.getRawAxis(5), the riolog displays no error messages but the motor would not spin. On the electronics, the lights are all solid like normal. We also tried using ControlMode.current and ControlMode.position with the Talon, but nothing can move our motor. This is our first year using Talons, is there something wrong with the code that caused the problem? Any suggestion would be greatly appreciated.

Your problem is with the units. In velocity and position modes, the units of the set method are in encoder units per 100 ms and encoder units respectively. Since your joystick axis returns a value from -1 to 1, and a CTRE encoder has 4096 encoder units per revolution, your code is trying to move your lift less that 1/4000th of a turn. That probably isn’t enough to move your lift a millimeter, unless you’ve got some crazy gearing going on and your PID values are huge.

If you’re just going to control this with a joystick axis during teleop, open loop control is probably good enough for you. In that case, just use ControlMode.PercentOutput.
If you want more precise closed loop control, you’ll have to do some math to convert the joystick value to native encoder units.