trouble setting IP addresses...

unsure how to set ip addresses for the devices - I followed the FRC document instructions but I don’t think it affected the devices and I do not know how to check this…
the driver station is updated but the cRIO is not - I was attempting this in order to do so.
Thanks in advance

EDIT: messing with the addresses must have done something because the driver station now labels the cRIO as invalid mode and system when connected properly

Just update your cRIO using the FRC cRIO Imaging Tool. You will tell it your team number, and it will use that to set the IP address correctly.

So I should be able to do that and it will set addresses for all 6 devices we need to change? Personally, I don’t have access to the actual equipment until Wednesday (another team member is working on it until then), but we managed to configure our laptop and router correctly. When I ran the imaging tool it failed when trying to connect to the cRIO (I had the unit’s port 1 connected to the PC). The information in the program window was as follows:

MAC address: (don’t know)
Name: temp (why temp?)
IP: (can’t remember - was 10.30.21.?)

Environment: LVIEW
Format controller - image was the latest zip file don’t know file name

We filled in the device name and team number in line correctly.

Is there anything wrong with the above info?

The cRIO Imaging Utility will only set the IP address for the cRIO based on your team number. You’ll have to set the other equipment (laptop, access point, gaming adapter and DS) as described in the configuration document on the FIRST web site.

Solved. Thanks for the input.