Trouble updating the latest Driver Station 2013


Frank just posted on the FRC blog ( that there is a manditory Driver Station update. I downloaded it and tried to install, but when I do, an error pops up:
If I click “Yes”, another error that says basically the same thing (but different file name) pops up.

Anyone else having this problem? Or, does anyone have a solution?

I should say that I have 2 HDDs in my computer and the Labview program is installed on the secondary HDD, NOT the OS drive. This all works, I do it with 90% of my programs and no errors with any of them.

Have you extracted all of the files and folders from the ZIP file onto your hard drive? If you try to run the setup.exe from within the compressed folders, it will fail.

I did unzip them before. I unzipped them again just to be sure, and it still showed the same error.

I know this sounds obvious, but Windows makes a ‘compressed’ folder look very much like a ‘real’ folder on your PC. It’s easy to think that you are running ‘setup.exe’ from a ‘real’ folder when it is actually still the ‘compressed’ folder. I’ve made this mistake before.

After extracting the files from the ZIP, make sure that you navigate to the ‘real’ folder where the files were extracted and run the ‘setup.exe’ from the ‘real’ folder and not the ‘compressed’ folder.

Another possibility is that the entire folder structure was not extracted from the ZIP. There are subfolders in the ZIP that must exist in the ‘real’ folder after extracting all of the files.

If you are running ‘setup.exe’ from the real folder and have extracted all of the subfolders correctly, then I have no idea what the real problem may be. We will be running the update this afternoon and will see what happens.

Wow! Strangely enough I tried something similar to what markmcgary said. I tried re-extracting it, but our team uses Google Drive to share stuff and, previously, I extracted it on the GDrive, but this time I just extracted it to the desktop AND I un-checked the “Check updates” box at the beginning (not sure if that did anything :-/ )

So, in a nut shell: extract the files to a physical place, not cloud storage (for some reason).

Thanks for the help everyone!

Thanks, but I just fixed the issue. Read my last post :slight_smile: