Trouble Uploading Code to robot

Hello,

When I “build” the code on labview it is successful. However, when I try to run as start up i get the error "connection failed. The network address might be invalid or the target is not responding. I already formatted the roboRIO and updated the firmware. I also reconfigured the router. I tried running as start up on using ethernet, wifi, and usb and it does not work, I still get the same error. I made sure that the ip on the project explorer is roboRIO-2161-FRC.local. Also, on the driver station the diagnostic tags show that it is connected to the robot radio, the robot, and wifi.

Thank you.

There are a couple of factors that can make this happen:

  • LabVIEW being blocked by a firewall or anti-virus in the computer
  • The mDNS service not running correctly in the computer
  • The IP address or local name not correct (which does not seem to be the issue in this case, since you mention you have checked it already).

Can you go over the suggestions shown in the following document and report back results?

LabVIEW for FRC shows Connection Failed to my roboRIO

I am using a Mac laptop and running into the same issue this morning. it says unable to access roboRio v 13. is there any solution for that? Thank you.

I did those suggestions in the document and it did not work. Can you go over the mDNS service settings?

I also turned off the firewall and the antivirus. It did not work.

see your build.gradle class. I changed version from 1.1 to 1.2 and it worked.

1.1 to 2.1 my bad

How do i do that on labview?

Are you using Bootcamp/VMWare or any other Windows Virtual Machine? The LabVIEW FRC libraries will not run/install in Mac.

We were able to fix this problem by loading code through and ethernet cable.

If you connect the roboRIO by USB and select 172.22.11.2 as the IP in the LabVIEW Project, you are bypassing the mDNS and should fix that issue.

If LabVIEW is still not able to communicate with the device, and the error you get just mentions that the target is disconnected, then I am more inclined to think there is some sort or firewall or blocking program not allowing the software to connect with the device.

If you are using a school computer, I would not be surprised that it has another service installed that is making this behavior happen. Have you tried with a different laptop and gotten the same results?

You said the Driver Station diagnostics tab shows it is connected to robot radio, the robot, and wifi but what about the Communications light in the middle of the driver station? Are you opening the Driver Station on your programming computer?

Hello,

it worked when i connected by usb and used 172.22.11.2 as the IP in the LabView Project. However, it still does not work when I try to use wifi. How do fix this?

Here’s something to try.
Connect via wifi to your robot.
Check the diagnostics tab on the Driver Station to see if it gives an IP address beside the robot status light. (usually it’ll be 10.21.61.2)

Switch to the Driver Station Setup tab and click on the down arrow beside the Team Number box to see if anything or multiple things get listed there.

Then you can try typing that IP address (10.21.61.2) into the Team Number entry on the Driver Station Setup tab, then click outside the box or hit Enter.
See if that changes the Communications indicator.

e.g.,