Trouble with Programming the EDU Bot

We seem to be having some trouble with programming our EDU Bot, we have the interface wired up to the computer via serial port, it seems that when we press the program button the LED turns orange like the directions says its suppose to, but when we go to download the program the LED resets and then it starts blinking again and on the screen it says that the download could not make a connection with the interface, so, does anyone have any suggestions?

I had the same problem.

What worked for me was to hold down the program button, click download, and then release the button.

Hope this helps you out.

I actually just suggested that in the other current programming thread :slight_smile:

Yes we have these ways i think our serial cable is bad or the port is messed up, we dont know we just have to think of something :confused:

I’ve seen bad serial cables exhibit this exact problem. Try swapping it with another cable, preferably one that is known to be good. The other thing to check is the port configuration. Make certain the baud rate, number of bits, stop bit and parity are set correctly. This is usually done through the OS on the laptop.

Were not using a laptop, does that make a difference in anything? Or can you use a desktop as well?

It should actually work better with a desk top they tend to be far less tempermental at least when you are dealing with ports.

Other things to check…
Cable, take any that you have and try it
download newest ifi loader

Just for clarification, they are no longer called EDU Robots, they are now Robovation robots.

Let people call them what they will. If that’s what it was called when it came out, that’s what it is.

Have you tried it with AC power connected vs with battery? We had some issues programming several vex controllers with some WPI owned laptops, where it wouldn’t work if there wasn’t ac power connected (wouldn’t work on battery). Took us a while to figure it out.

How did you have the AC hooked up to the EDU Bot, it seems if you were to put more then 7.2 volts it would damage the interface. The only place on the interface to hook up any source of power would be the battery.

I think he means AC power to the laptop, to the best of my knowledge you can’t (easily) run the edu rc on ac power, check my post in the other thread (the one by muy deficil)and see if it helps.

Alright this is totaldomination under my friends account, i think i may have found the problem wut version of the compiler do u need to run the programming succesfully?

We used 1.0.7 for the ifi loader and 6.3 with the compiler.

Those should work fine with the EDU.
The 6.3 is the version of MPLAB not the compiler. To see what version of the C compiler you’re using, look under c:/mcc18/README.C18 and the version will be at the top.

What version of the EDU code did you start with?