Troubles connecting to RobotRio

We are having issues connecting to any of our 3 RobotRios with labview to deploy new code. The laptop is able to connect to the RRIO and image it with a USB cable. We can also access 172.22.11.2 and http://roborio-5090-frc.local with a USB cable.
We are unable to “connect”" o the RRIO through labview which is not allowing us to deploy code. Our test to “Connect” is to right click on target in labview and choose the “connect” menu option. When we do this we receive the error messages in the screen shot attached.

We have tried a normal network cable and 172.22.11.2 was not reachable.
Firewalls are turned off, and we have tried multiple Windows 7 laptops and even a fresh install on a windows 10 laptop.





I don’t see the problem from what you’ve posted. Does the driver station on the same computer connect to the roboRIO? You may also want to try running LabVIEW as administrator (right click and Run as Admin). You can also try changing the Target Properties to 172.22.11.2 and try the USB cable.

Please post back with results of these tests so that we can identify what is causing it.

Greg McKaskle

I found the problem. I noticed the laptop was also connected to a wifi connection that was connected to the internet. Once I disabled the wifi on the laptop, I was able to connect to the RRIO via the USB and deploy code.

It may also be feasible to leave the wifi on, but change the priority of the interfaces in the control panel.

Greg McKaskle

Changing network priority was something I couldn’t figure out, but just found this page to explain how to do this:

https://support.microsoft.com/en-us/kb/2526067
I’m posting this for other teams having similar issues to read and follow when necessary.

I made the LAN connection a higher priority than the WIFI connection on our laptop but it didn’t seem to help. Turning off the WIFI connection while tethered to the RRIO through a LAN chord seems to be the reliable method for us.

Thanks for the help.