Troubleshooting OMIO X8-2200USB


We have an OMIO X8 (USB). When running gCode things generally start off well but part way through a run, the machine begins to misbehave. Here are some examples:

While cutting out a part, the machine decided to, at depth wander straight across the stock damaging both the part being cut and the toolbit.

While drilling out some holes (there are many of them) the machine starts off very nicely then decides to put the next series of holes where it wants to put them, not where they are supposed to be.

Thankfully we are using plywood (prototypes for later cutting metal) but this erratic behaviour is problematic.

The attached desktop computer is running Windows 10, has a wifi card, a reasonable amount of RAM. We tried turning off the wifi thinking maybe there is some process or electromagnetic interference, made no difference - the next task exhibited the same behaviour but at a different place in the gCode.

Any suggestions on getting this promising machine to behave reliably is welcome.

Thank you for your expertise. We are rebuilding this year and hope to use both newly acquired 3D printing skills (with carbon fiber PETg) and CNC Routing during the 2023 FRC build season.

Thank you.

FRC 7509

1 Like

PS: Our observation is that the erratic behaviours affect the x and the y axes, not the z axis.

Some pictures of what’s happening would help.

Double check your wire attachments everywhere, and double check the set screws on motors. A loose wire or two could cause a motor to completely drop out seemingly randomly, and those set screws can cause it to drift as it’s cutting.

It also wouldn’t hurt to do a test run with your z set high, so it’s not actually cutting anything.

1 Like

Make sure the stepper motor couplings set screw are tight.

1 Like

Thanks for the response. Generally, the pattern of misbehaviour is for there to be a kind of “fart” sound coming from the machine (source hard to track down but seems to be resistance to x or y movement) and the affected movement comes up short then the next operation continues from the wrong place.

There is no evidence of ongoing “drift” - the dimensions and hole placements for example are accurate except, of course, when going astray.

Would adding lubricant to the screws turned by the stepper motors, or the gantry rails help?

I’ll check our video to see if we have this recorded…

Would background tasks on the computer potentially disrupt gCode flow from the computer to the OMIO controller or is there a sufficient buffer on the OMIO controller such that this is not an issue?

We have Fusion 360 typically open in another window and this is connected by wifi to their cloud server.

I would bet that’s the set screw grinding against the shaft. If you remove the motors, you’ll probably see the shaft chewed up a bit.

In looking at the pattern of disruption, does it seem to happen in the same location on the table, or is it random? If the same location, that may indicate a “rough spot” in the travel - swarf or a manufacturing defect that creates a high load at that location, causing the set screw to slip. It may be worth disconnecting the motors, getting some vice grips on the shaft and running it by hand to see if it runs smoothly through the full range of motion

If it’s random, then you likely need to tighten things up more, and consider your speeds and feeds, you may be too aggressive. Resetting your Z 0 to be above the work piece and running it through (so it doesn’t actually cut anything) may help identify the problem, as you’ll have nothing but the mechanical resistance in the machine itself at play.

If it’s random, then you may be pushing things too hard for the material you’re cutting, causing the same thing periodically.

Unlikely. We’re running ours on an old 2016 MacBook Pro (running Windows 11), with Fusion 360 in the background, and have never seen that to be a problem.

1 Like

Windows is not a real time system. So anything in the background can potentially disrupt control to the Omio. I would not run anything other than the mach 3 program when running the Omio.

1 Like

The sound you’re hearing may be the sound of stepper motors missing steps. This would be due to the load torque exceeding the motor torque. This can happen from mechanical binding in your machine’s linear motion system or from pushing it too hard during a cut. It’s also possible that your rapid speed and/or acceleration are a bit too high. Stepper motors lose torque at higher speeds. Try dropping your rapid speed and your acceleration and see if it performs better.

Thanks for the insights. The noise usually occurs when the mill is above the material and moving from one location to the next. This speed is far lower than when jogging in the x or y directions.

We’ll see if we can adjust that speed - have to figure out where/how (in Fusion 360).

As others have mentioned, tighten your motor couplers.

Make sure you are setting your feedrate to something below 200IPM (~4000mm/min).

Try using the Avid CNC CAM post file when generating g-code, that’s the one that I use with good results. This may fix the endmill dragging.

1 Like

Make sure to ground your machine, and its insides if need be. We ran into a lot of issues with skipped steps at random because the machine wasn’t grounded internally.


Just to rule it out, can you post your G code file that you were running when the issue cropped up?

That is the sound of a stepper motor losing steps. Often mechanical, it can be electrical.

Set Z to well above the material and have several people watch closely for it to happen.

I have similar issues occasionally with my machine. I have a feeling that it’s got to be a windows or usb issue.
I’ve had it randomly slow down and make skipped step noises in the middle of a easy cut and then suddenly take off towards the machine home without raising the z axis. It does seem more common at higher federates, but it doesn’t act like its just a skipping stepper.

I’ve just done a clean-up on the computer, deleting non-essential applications and constraining what Windows can do in the background, e.g., indexing files, firewalls, updates, notifications, sleep mode, screen saver, power settings, etc.

We still have Fusion 360 on that computer which we happily run in stand-alone mode if we need to tweak toolpaths without it touching the cloud (Airplane Mode).

Part of our set-up before using the CNC Router will be to set “Airplane Mode” so that wifi is silenced.

Am also adding a double-shielded high quality USB cable (arrives later today) and a UPS with true sine wave output. Whenever the ventilation here kicks in, the lights brown out a bit - maybe this is also a trigger for CNC erratic behaviour.

I’ve not (yet) cracked open the controller box re grounding - I want to see if these steps solve the problem.

Checked stepper motor couplings nice and tight. We were running at 1000 to 3000 mm/min.

What advantage does Avid CNC CAM offer?

That’s odd behavior alright.
So try to reproduce it with Z=0 a few inches above the board, so nothing gets broken. If it happens once, see if you can make it happen twice. If in the same spot, check G Code and see if the Win machine CPU is getting near 100% (unlikely, but…)

Yes, it could be a Windows issue, and cleaning up the PC will definitely be good for everything.

One troubleshooting technique is players and game: Who are all the players that can cause the game to happen? Players are the components, game is the observed behavior. Make a comprehensive list (best you can) and see how many you can eliminate. I suspect you have eliminated the mechanical issues?

Good luck!

It’s not CAM, just their post processor. It moves the tool to sane heights when starting programs. You can select different post processors when exporting CAM from Fusion