Trying to build Using Github Actions

I was trying to build my code using github actions following [Setting up CI for Robot Code using GitHub Actions — FIRST Robotics Competition documentation] tutorial from wpilib. I have tried this a couple times now and it’s never worked for me. What ends up happening is that the compiler fails to find “frc/smartdashboard/Smartdashboard.h” , <frc/shuffleboard/BuiltinWidgets.h> and a couple other shuffleboard/smartdashboard dependencies. This is really wierd because it resolves everything else including the vendor libraries just fine.
I suspect this is a bug with the frc toolchain that is being used, but frankly I’m suprised that noone else has reported the issue so maybe i’m doing something wrong??

The error log can be found here (pastebin)

To clarify:

  • I’m building with github actions for continuous integration.
  • The link to the failed job is here
  • I don’t know where exactly I hshould open an issue for this if it is a bug.

Some help would be awesome.

Since it builds on linux, and linux uses a case sensitive filesystem, things that may have built on windows with the wrong case will fail.

frc/smartdashboard/Smartdashboard.h should be frc/smartdashboard/SmartDashboard.h
frc/shuffleboard/BuiltinWidgets.h should be frc/shuffleboard/BuiltInWidgets.h

5 Likes

Oh my god it actually worked thank you so much

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.