"Unable to access jarfile FRCUserProgram.jar"

We’re trying to bring up our 2018 FRC code but, regardless of the Java application we build and deploy, we are always seeing “Unable to access jarfile FRCUserProgram.jar” in the Eclipse RIOLog window after the code is successfully copied to the robot. We initially tried with our 2017 code ported to the 2018 WPILib/CTRE_Phoenix but then moved back to a completely empty skeleton generated with Robotbuilder in case something we were doing was messing things up.

So far, we’ve SSH’d into the RoboRio and verified that /home/lvuser/FRCUserProgram.jar" exists. We’ve also copied the file back via SFTP and verified that it is identical to the file generated by Eclipse. We also tried cmod’ing the file in the RoboRio file system to 777 in case it was a permissions issue. We’ve also reimaged and rebooted the RoboRio a couple of times. No luck.

At this point, we’re stuck. Can anyone offer any suggestions on the next step in diagnosing this problem?

Quick update - based on a hint provided over in the WPILib git issues section, it seems this can be caused by a corrupted robotCommand file deployed to the robot. In our case, there was a non-printing character appended to the end of the file. I’ve fixed this and will update the status once I verify that it actually fixes the problem (I have no drivers station to play with this afternoon).

I’ve now managed to verify that this was, indeed, the problem. Fixing the robotCommand file cures the problem.