Unable to Assign ID to Jaguar with BD-COMM

Hi,
We are trying to assign IDs to a Black Jaguar from BD-COMM. We made a CAN to serial adapter. We also terminated the other port with a CAN terminator.

http://dl.dropbox.com/u/16232282/black_jag_annotated.jpg

The steps we are taking are:

  1. Connect Black Jaguar serial port to computer with a 6P6C to RS232 adapter. As the picture shows, we recrimped the wire so that it is reversed.

http://dl.dropbox.com/u/16232282/6_pin_annotated.jpg

  1. Open up BD-COMM to the System tab. At this point, the Black Jaguar has a solid yellow light.

  2. We change the id to 2 and click assign. The jag never turns green. We press the user button within the 5 second time window. Sometimes it turns solid yellow for a bit.

Afterwards, the Black Jaguar blinks a slow yellow and we cannot locate it in BD-COMM.

From what it looks like, we can’t find anyway to assign an ID to the Jag. We’ve confirmed that the adapter is working.

Any troubleshooting suggestions? :confused:

Thanks!

Those are some beautiful pictures of how to wire the CAN bus correctly.

The first thing I would check is your termination resistor. Is it shorting the CAN bus together?

What happens when you take it out?

Do other Jaguars have this issue?
Have up updated firmware?
Can you control motors and set parameters?

The first thing I would check is your termination resistor. Is it shorting the CAN bus together?

Not necessarily the problem. Since the picture makes it appear as if the Jaguar is directly connected over the serial port, the CAN bus shouldn’t even be used yet (It would be purely serial communication).

If you can talk to the Jaguar try re-flashing its firmware, if not then try the BDC-Comm “Recover Jaguar” setting to see if it is stuck in a boot-loader state.

When connected with BDC-COMM, before trying to update the ID, can you see proper responses to commands? For example, set the Percent VBUS to something other than neutral; does the LED indicate what it should?

-David

+1 on updating the FW first. that fixed a bunch of 09 gray jags that would not reset the ID.

also make sure you have an un-shorted, 100 ohm resistor in the serial adapter and terminator… i personally do not recommend the direct-crimp terminator method touted by TI. it does not seem all that robust as most RJ-12 plugs i have seen are for braided wire (the contacts piece and bisect each wire); while resistors are solid wire. also, i have heard they tend to short out easily. I recommend crimping some wire in the plug and soldering the resistor to the wires; that reduces the risk of a short and is the correct use of the plugs.

Our main programmer (el-zoroo) left already, so I’m just going to quickly sum up what we did today.

   We tried some more things today to fix this. Replacing the directly-crimped terminator with one with some wire soldered to the resistor, but that didn't do anything. We also tried reloading the firmware, but whenever we tried, BDC-COMM complains that it can't contact the boot loader. We verified with a multimeter that the cable itself works fine. We also tried using a usb-to-serial adapter instead of this laptop's built in serial port. BDC-COMM defaulted to the built in serial port (1), and the jaguar thought that it had comm (solid yellow light), although BDC-COMM wouldn't allow us to do anything besides attempt to assign a new board ID. However, when we switched it to the usb adapter (4), the jaguar lost comm (blinking yellow light), but BDC-COMM allows us to try to set the voltage, etc. Using the Classmate with the usb adapter has the same effect as using the built-in serial port on the other laptop. We're planning on messing around with the serial port's data rate, bits per second, etc. in the device manager tomorrow.

The only time I’ve had that “could not contact bootloader” error was when I had my RS232-CAN converter cable backwards. (The other symptom I had with that configuration was that the only number it would enumerate was 0)

Go ahead and play with the RS232 configuration.
Also, try with your other Black Jaguar and see if it’s any different.

the boot loader error just means you have no valid connection.

verify you have the correct pinouts for the serial adapter:

(RJ12, DB9)

1, 3
3, (terminator)
4, (terminator)
5, 5
6, 2

also verify you have the correct COM port in bdc-comm, in case you have multiple ports on your computer.

Hi, another update.

We verified our adapter’s pinout again, and it still looks good.
We also swapped to our other black jag and that’s also not working.
Both jags display a solid yellow light until BD-COMM tries to do anything.
We bought a Serial to USB convertor, in suspicion that our serial port was not working, but that does not fix anything.
And we also verified that using a non-reversed 6 pin cable does not work. When we reset the jag, the light turns red and green for a split second, then goes back to flashing.

Any other recommendations? :ahh:

Update: We used the wire as it came directly to the serial port and it works! :confused: I think the reversed cable is for the cRIO. Thanks for the help!