Unable to connect to limelight.local:5801 on select computers

My team purchased a Limelight 2 for vision this year, and after setting everything up, we’ve found that on some laptops and phones we can connect to limelight.local:5801, but on my computer and the main team laptop we are unable. We receive a “no internet” page instead. We’ve tried suggestions in another thread, like changing IPs and reimaging the limelight, to no avail. Has anyone else had this issue?

Do you have bonjour installed?
Following these steps fixed this issue for us.

We do. I feel like it might be something in the laptop’s network settings, but we’ve tried several things with no result.

There are a few trouble shooting details. With LL2 what is the status of the amber LED.
Flashing = DHCP (I would connect direct to LL2 with PC set to auto obtain IP)
If solid = static ( connect direct with PC IP set to static)

Make sure Bonjour is installed. This will translate “limelight.local” to the IP address of the limelight.