Unable to connect to roboRio

I am currently unable to connect to the roboRio in order to upload my robot code. So far I have tried using both ethernet and usb. The roboRio imaging tool recognized (and updated) the roboRio using both connections. The dashboard shows communications using both methods. I have my wifi turned off and I’ve switched to a static IP (still recognized by the dashboard). I have been able to ping the roboRio. Despite all of those signs of communication when I try to load my code through labview I get “unable to connect to target”. I’ve tried changing the target IP address/DNS name from the default name (with appropriate team number) to the static IP 10.27.07.02 and still no luck.

What else can I try or am I overlooking something?

Thanks

Try this,

  • Use the roboRIO Imaging Tool to disable startup code, Apply
  • Reboot the roboRIO
  • Download your code
  • Use the Imaging Tool to re-enable code on startup, Apply
  • Reboot the roboRIO

DisableStartup

Some user code locks up or slows the roboRIO ftp operations when they are taking a lot of resources, i.e., lots of loop processing, lots of code, slow loop processing, etc.
Ftp operations run at a lower priority than the user code, and if the code isn’t giving up enough processing cycles to allow other background tasks to run you’ll see behavior like this.

If the process above works, then it’s time to look at streamlining the code.

Thank you. I remember seeing this as a possible solution but for some reason hadn’t tried it. Things are working now. Since this was a first, very rough iteration of our code we will definitely have to go back and look and streamlining where we can.