Unable to connect to robot

After using the roborio imaging tool to update the firmware, we found that the robot cannot be connected to the diver station. Do you know how to solve this problem? Everything was normal before the update

1 Like

Did you format the roboRIO with FRC_roboRIO_2022_v3.0.zip (assuming a roboRIO 1.0)?
If you updated the firmware (6.0.0f for a roboRIO 1.0) , then the roboRIO has to also be formatted with FRC_roboRIO_2022_v3.0.zip .

It would help confirm what you have if you provided a screenshot of the roboRIO Imaging Tool window showing the Current Image and Firmware versions.

Second, are you connecting with a USB cable or direct/indirect Ethernet or WiFi?
Have you tried more than one network path?

Third, what does the Driver Station Diagnostics tab show as green?
And is the Driver Station Communications indicator red?

① Yes, we use a brand new version

② We have tried many ways to connect, WiFi, USB and Ethernet have been connected

You mean the FRC_roboRIO_2022_v3.0.zip image, right? The other one is for the RIO2 and will fail on a RIO1.

Yep, thanks for the catch. I copied the wrong line and should have asked which roboRIO they had.

Your Team number must be set in the Driver Station (it is currently team 0), before the RIO can be found.

We have set the team number. The results of the pictures you see excluding the team number are consistent

Your PC Firewall is on and can be blocking connection. You can test if it is blocking by turning off the firewall.

Here are some networking troubleshooting steps: roboRIO Network Troubleshooting — FIRST Robotics Competition documentation

Try to get a screenshot of the roboRIO Imaging Tool window while connected to the roboRIO via USB.

Thank you for your answer. We will try this scheme

Doesn’t a green firewall light indicate the firewall is off? If it were on, it would list which profiles were enabled to the right ("[Dom,Pub,Pri]" in like a dark orange/brown color), or did something change in an update?

Naw, it’s been too long since I looked at the Firewall indicator.
The missing “l” should have been a tipoff, too as it removed the text for (Dom, Pub, Prv).

They do seem to have all three network connections attached (Enet/Wifi/USB) instead of just one.

The problem is that you are in roborio 1 The latest version or FRC has been updated on 0_ roboRIO_ 2022_ v3. 0.zip image

Thank you for your answer. We have solved this problem

Great!
Good luck in your competitions.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.