"Unable to contact the Bootloader" When updating black jaguar

I have recently been trying to set up CAN using a black jaguar as the gateway from the cRIO. I made the cables exactly following the diagrams and am sure they are correct. When we plug our black jaguar into the computer(Just the black jaguar with the terminator) and open BDC-COMM the blinking yellow light changed to solid yellow, and we can get “Connected”. If I then go to update firmware and select the correct file, I get the error “Unable to contact the Bootloader” I tried using different computers, but I get the same error every time. Also, when trying to change the ID number, it appears to be working but we never get a flashing green light, and we have been unable to change it. I looked around on the forums but never saw a solution to this exact problem. Also, the Recover Device option, has the exact same “Unable to Contact the Boot Loader” error. Are there any solutions to this or is it necessary to RMA our Jaguar?

Are you able to control the Jaguar with BDC-COMM. For example, can you set the Percent Voltage output and do you see a response from the Jaguar?

What Firmware Version does it show when you go to the System tab?


When you put the wires into the DB-9 part of the CAN to RS-232 adapter did you push them in until the clicked? You could have loose connections to the Jag, making the signal only work for some things.

Sorry about the delay, I put CAN on the back burner for a bit to get everything else done.

I’m fairly sure that our cable is correct and securely plugged in. We are not able to control voltage or anything like that, and Firmware/Hardware version say 0. It seemed like our black jaguar was communicating, but as I looked into it, I could get BDC-COMM to display the exact same things, (Connected, Trusted), even when the black jaguar wasn’t plugged in. This makes me think that either our black jaguar is dead, or something is wrong with our cable. The blinking light on the jaguar DOES turn solid when we plug it in though, so I’m less inclined to think it’s the cable. Also, if we unplug the black jaguar, it goes back to flashing yellow unless we’ve tried to update it or change the firmware. In that case, it appears to be “frozen” on solid yellow, even after all of the cables are unplugged. It remains this way until we turn it off and back on.