Unable to deploy C++ code

Language: C++
IDE: Eclipse

We receive the below error when we try to Run As -> WPILIB C++ Delpoy to the robot.

Unable to instantiate specified input handler class org.eclipse.ant.internal.ui.antsupport.inputhandler.ProxyInputHandler : java.lang.ClassNotFoundException

The project builds just fine. I cannot find anything that references this error and makes sense to me and limited understanding of Eclipse.

We are able to get the labview programs to deploy but we would prefer use C++.

Any help would be appreciated.

Are you deploying with ant build or with WPI Deploy?

WPI Deploy I think.

We are following the WPILib tutorial here:


did you follow the install procedure for eclipse? It looks like it might be some sort of java problem

We followed the C++ instructions, I have tried reinstalling/repairing the toolchain and plugins, but I am starting to wonder if we grabbed the wrong Eclipse installer by mistake.

That could do it I would also try to verify you got the right java for what your doing. If you saw in Screensteps JAVA 9 does not work.

We did get C++ version. We do not have any of the Java plugins or environment installed.

but you do need to install Java from oracle to run eclipse.

Right, We have Java 8 installed on the computer, but do not have any of the Java stuff in the Eclipse installation.

I tried reinstalling Eclipse and when I do that I get some huge wall of text error and it will not start up.

That might be a problem

Thank you for your help. We did get it figured out. The issue was that we had Java 8 64-bit installed and we were trying to use 32-bit Eclipse.

Having someone to talk through some of this helped alot, thank you for taking the time to engage with us.