Unable to flash firmware on PDP

I’ve been trying to get the PDP to take the newer firmware (1.37). It currently has 1.30.

I navigated to roborio-41.local and tried to update it through the web interface. I can see the PDP enumerated in the list, however when I click “Being Update” one tick in the progress bar lights, then I one of a few errors:


CTRE_DI_DidNotGetDhcp When this happened the PDP stayed in bootloader and required a power cycle. I could not communicate with the PDP until I cycled it.

E_SYSAPI_FAIL I think this was my fault for not logging in as admin after power cycling the roboRIO.

The power distribution panel is the only thing on the CAN bus. The jumper for the terminator resistor is ON.

I have not updated the roboRio’s firmware as I read that some were bricking, and I was planning on waiting until that was fixed or I read about the root cause.


Just as a sanity check can you try field-upgrading a different device, like the PCM (or a Talon SRX if you have one). I’m just trying to confirm if the issue is PDP side or RIO side. Sounds like the PDP is entering boot-loader ok if you are able to see the green/orange blink on the PDP.

I heard of one other case (another team) where this exact symptom was described. They ended up re-imaging their RIO and the problem “corrected itself”. But I don’t think that should be necessary (likely something else was going on).

It shouldn’t be that difficult to flash the PDP, can you try a clean reboot of the RIO and then opening a fresh browser. When the PDP comes up just try doing a “Light LED Device” checkbox and press save. See if the PDP blinks fast-orange in response to the checkbox.

I tried reflashing a PCM, no dice. I have tried 2 different computers with 3 types of browsers (chrome, firefox, and internet explorer).

I was able to get the PDP to respond to the light device LED checkbox, however this could only work once unless I power cycled the system (pdp and rio).

I reimaged the rio and the firmware took on the PDP flawlessly.


Just to add a me too: we had to re-image the roborio before we could get the PDP and PCM to upgrade. We had the same error message above as well.

We found a break in the CAN bus caused the DHCP error noted above. We had one talon srx not powered (waiting for the rest of the build) as soon as we powered that talon up I was able to flash the firmware on our PDP.

Hey everyone, thanks for the input. Just to wrap this thread up, checkout Section 16.28 in latest software reference manual. Good luck this season!