Unable to locate I/O unit over USB.. new error

ok, so we deploy the code on developer, switch users to driver or w.e. and we cannot make it respond, we get an error
Unable to locate I/O unit over USB
Check the cable
Make sure the CyMiniProg3Service has been started in the Service Manager
Make sure the unit has been programmed

I looked up CyMiniProg3Service and it says it may be adware, but also see that it has happened to another FRC team, they were told to clean it, but i didnt see any results, we couldnt find the service last time, we will try again tomorrow, but have any other teams ran into this problem? does anyone have any ideas to fix it?
Our boards and USBs are all connected, we ran our program once, and had no problems, later we tried to run and got an error message that one may already be running, but we checked and there was nothing running, not even in task manager, we fixed that, then later tried with the same connections and same program, and got this error.

A lack of the cypress should not block the robot from running. If you can’t enable the bot then you have very serious problems (unless the stop button is unplugged :stuck_out_tongue: )

CyMiniProg3Service is the communication program for the I/O board on the DS. You can see if that is running by typing “services.msc” into the run dialog on the Developer Account and scrolling down to that service. If it says Disabled or Stopped, make sure to start it and try again.

Also, run the driver station updater again and tell it to uninstall everything. Then run it again and install everything. There is a bug in the updater that prevents the Dashboard and I/O board software from updating normally.

If you not being able to enable the bot is the problem, check the lights on the far left of the Driver Station. Communications, Robot Code, and Stop Button should all be green. If one of those isn’t, then your problem is unrelated to the I/O board

Are you using “fast user switching”? The Driver Station application doesn’t like running in both the Developer and Driver accounts at the same time. As a general rule, always log off the Developer account before using the Driver account, and vice versa.

If you’re doing software development, you can (and should) run the Driver Station application in the Developer account. You’ll find it in the Start Menu along with all the other programs on the Classmate.

Some of what you describe makes it sound like you’re confused about where the programs actually run. The task manager won’t show you what’s running on the cRIO in the robot. The “may already be running” error message you mentioned is probably talking about a robot program, not a Windows one.