Unable to run program as startup

Hello builders,
Our code works when executed through the Robot Main VI. However, I seem to be unable to set my program to run as startup on my robot. I had built the program but it doesn’t seem to build all of the dependencies. “NI_Vision_Acquisition_Software.lvlib” and “NI_Vision_Development_Module.lvlib” are locked and I cannot build them. Here is our team’s program if it helps: https://github.com/PLS5618/DeepSpace-Robot-2019.

Olivier D.
PLS 5618

Before you click “deploy” or “run as startup” you need to click “build” to build the code into a deployable project. Every time you make a change and want to upload new code, you have to re-build. Then you should be able to deploy permanently.

It doesn’t work if I try to set as startup after building (successful build message). As I said, it looks like LabVIEW doesn’t building the two dependencies in the screenshot.

Look at the NI License Manager to see if you’ve activated your Vision license.

It should be green and look like this:

After verifying those dots are green, right-click and choose “Build.” If that doesn’t complete successfully, please show us that error dialog. The problem you’re running into now is based on the build itself. Either you haven’t done it or it’s erroring. We’ll need to understand those errors to help.

Everything is licensed (all green dots).

There is no error message when I build, it says that the build is complete.

Additional info: When I go in my dependencies, the two libraries in the message are locked.

Also, you might want to know that I copied the code from the vision examples in our program, that might be a cause to the problem.

What are you doing in your code with vision processing?
Perhaps you are calling products that we do not have through FRC?

As a test, can you create a default project, build, and run it as startup?

That will be true for everyone. Right-click one of the locked libraries and choose the “Why is Library Locked?” option. It will explain the lock is related to password protection. That’s something that happens with a lot of NI VIs that are shipped as products (such as the Vision Development Module). It shouldn’t change any behavior you’re seeing otherwise.

As a sanity check, you can right-click the build spec and choose “Properties” rather than “Build” or “Run as Startup.” If you do so, the first tab is the information tab. It will share a local destination directory for your builds. It should look something like: C:\Users[Windows Username]\Documents\LabVIEW Data\2019 Robot Project\Builds

Once you have that directory, you can go to that path to see if anything exists in it. This is where I’d expect the project to look for the built executable when deploying it to run as startup. Is this path empty?

Update the tests we did this weekend:
The program was built in the designated folder, but LabVIEW didn’t detect it while setting it as startup. We changed the folder and it is now deploying. However, even after setting the program as startup, the FRC Driver Station doesn’t recognize the running robot code. I know it’s on there because LabVIEW tells me that a real-time application is running when I run the code from Robot Main, but the indicator on the Driver Station stays red. This might still be caused by some weird settings for the build. Will do more tests Monday and Tuesday night and try to post updates here.
If you have any ideas, even as of now, please tell me :slight_smile:
Olivier D.

We’re a Java team but a similar error we get is “Robots should not quit, but yours did!” Usually the reason for that is you defined two DIO / PWM / whatever devices on the same port, causing the code to crash. I’d double check all the initialisations for your devices to make sure you’re not defining the same thing twice on the same port.

@Uberlyuber The thing is, the program works when just temporarily sending it to the robot.

LV wouldn’t crash in this instance. Instead, it’d throw an error to the driver station and then the second device trying to use those ports wouldn’t work. He also wouldn’t get the error about code already running if it errored and quit.

@olidem123 If you create a default project, build it, and send it to the robot… which lights do you see green on your driver station? Which version of LabVIEW/Update Suite are you using? Have you called into the support staff from 1-7PM Central to see if they can help get the code running?

Well… Seems like LabVIEW doesn’t like accents on letters. Everything works now, we renamed one of our custom VIs to remove a character that was not working. Thanks everyone for your help :slight_smile:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.