Unable to update WPILib Robot Dev Core

Eclipse (Neon2 for FRC C++) keeps saying an update is available for WPILib Robot Development Core ver 2017.2.1 . When I try to install it, I get an error message with several lines like “No repository found containing: osgi.bundle,edu.wpi.first.wpilib.plugins.core,2017.2.1” I have tried Googling the problem and searching StackOverflow. Several posts look similar, but the suggested fix of restricting the repository sites searched doesn’t work here. I get the same result at work and at home, so any firewall problem would probably be on my laptop. Is anybody else getting this message? Is there a fix or workaround?