Unable to use Pathfinderv2 in Gradle


#1

I am trying to use PathfinderV2, but whenever I try to build, it gives the same error saying to download all of the libraries from Maven. If I run ./gradlew downloadAll, it keeps giving the same error that it cannot download Pathfinder-JNI-2.0.0-prealpha-linuxathenadebug.jar because it does not exist on the server. Here are the two outputs of ./gradlew build and ./gradlew downloadAll:

# ./gradlew build
> Executing task: gradlew build  -Dorg.gradle.java.home="C:\Users\Public\frc2019\jdk" <

> Task :downloadDepsPreemptively FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':downloadDepsPreemptively'.
> Could not find Pathfinder-JNI-linuxathenadebug.jar (grpl.pathfinder:Pathfinder-JNI:2.0.0-prealpha).
  Searched in the following locations:
      https://dev.imjac.in/maven/grpl/pathfinder/Pathfinder-JNI/2.0.0-prealpha/Pathfinder-JNI-2.0.0-prealpha-linuxathenadebug.jar

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 1s
2 actionable tasks: 2 executed
Dependency Error!
GradleRIO detected this build failed due to missing dependencies!
Try again with `./gradlew downloadAll` whilst connected to the internet (not the robot!)
If the error persists, ensure you are not behind a firewall / proxy server (common in schools)
# ./gradlew downloadAll
> Task :downloadAll FAILED
Resolving: annotationProcessor
Resolving: archives
Resolving: compile
Resolving: compileClasspath
Resolving: compileOnly
Resolving: default
Resolving: jrefrcjre
Resolving: nativeDesktopLib
Resolving: nativeDesktopZip
Resolving: nativeLib
Resolving: nativeZip

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':downloadAll'.
> Could not find Pathfinder-JNI-linuxathenadebug.jar (grpl.pathfinder:Pathfinder-JNI:2.0.0-prealpha).
  Searched in the following locations:
      https://dev.imjac.in/maven/grpl/pathfinder/Pathfinder-JNI/2.0.0-prealpha/Pathfinder-JNI-2.0.0-prealpha-linuxathenadebug.jar

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 1s
1 actionable task: 1 executed
Dependency Error!
GradleRIO detected this build failed due to missing dependencies!
Try again with `./gradlew downloadAll` whilst connected to the internet (not the robot!)
If the error persists, ensure you are not behind a firewall / proxy server (common in schools)

Any help would be much appreciated.