Unresponsive USB ports

Hey guys,

I was hoping some of the more technologically minded people on this forum might have some advice on how to fix my problem.

I updated Windows 7 on my laptop yesterday as I shut down, and today none of my USB ports are responsive. If I plug my devices (mouse, flash drive, ipod etc) into a hub, and then the hub into a USB drive it recognizes everything. If i plug them directly into the port then I get nothing.

Any advice on how to fix this?

I’d really appreciate it.

Check your laptop manufacturer’s website for Windows 7-specific drivers.

Though Windows 7 has a plethora of pre-installed drivers, there’s a chance that it doesn’t have the ones you need.

I tried that, the weird thing is that nothing I plug into it is picked up by the USB. If I plug it into my friend’s laptop they are recognized, but not by mine. So I don’t know if it’s a Windows problem, or a hardware problem.

Did you try rebooting (I know stupid suggestion)? The simplest answers are sometimes the right ones

Yup, did that too. It’s rather frustratiing. I tried going on Alienware’s website, but apparently they don’t believe in customer support.