Updating Jaguar Firmware for CAN

We are trying to configure our Jaguars for CAN, and are following the instructions on page 17 of this document:

However, we are stuck on Step 4, as the Board ID dropdown menu is greyed out even after we went through step 3 successfully with all of our Jaguars blinking green during ID assignment and then blinking yellow with their ID numbers.


Any help would be greatly appreciated! :slight_smile:

I have the same problem. I also have a blinking yellow light. Instead, however, BDC-COMM is connected to COM Port 4 but it did not connect automatically I had to select “4” from the drop down box (I’m using a USB to serial cable). Also, there is a “Trusted” icon in the top left corner of the window. Otherwise, everything it the same, all grayed out and no board information. I tried resetting the jag while assigning a new board ID but even after the countdown the board information isn’t any different. I would really appreciate any help, been struggling with this for a couple days.Thanks!

With BDC-COMM-107 I’m getting a “COMM FAULT” and “Can’t contact bootloader” error when I try to update firmware (black-jag 107).

Just for the heck of it, I also tried older versions of BDC-COMM. With BDC-
COMM-101, before I could even try to update firmware, I got a “Could not connect to specified COM port” error (no matter which usb port I try). With BDC-COMM-99, I get the same reaction as with BDC-COMM-107.

At least the USB to serial cable has more relable/replicable results. With the RJ-12 cable I couldn’t even get BDC-COMM to give me the “Trusted” label in the top left corner of the window.

Sounds like you are not communicating with the jag at all. Is your serial to CAN cable home made or ‘off the shelf’? Do you have a second cable you can try (maybe you have a bad one). Try only connecting to a single jaguar (if you aren’t already). Do you have the terminating resistor installed?

This usually means the serial port is in use by another application. Are you sure you didn’t accidently leave BDC-COMM107 running while you were trying to use this one or something?

I fixed the problem with not being able to connect with the COM port by trying a couple different laptops. The serial to CAnN cable came with the kit of parts and the USB to serial cable was ordered off amazon. This is the product: Plugable USB to RS-232 DB9 Serial Adapter (Prolific PL2303HX Chipset) – Plugable Technologies. Yes we’re using a CAN terminator we made it using instructions made by Team 1718 online. We’re using a single black jag right now. I haven’t tried connecting to multiple jags yet and I figured I would try the black jags before working on the old tan ones. This is what the BDC-COMM screen looks like right now. Thanks!

Solved this problem on my end, electrical has just informed me they did the cabling wrong.

Always makes you feel a little better when it’s not your fault :stuck_out_tongue:

CosmicCricket, can I ask you what you did to solve the problem on your end. How did you get rid of your blinky yellow lights?

After you assign an ID, the lights should blink a certain number of times depending on your ID. If it’s happening beforehand, you should look at your cabling.

Our cable actually tested fine on a voltmeter, but we found out that whenever we pushed it into a port one of the wires would end up slightly out of place, which messed the entire thing up.