[URGENT]Unable to connect to crio

My team has two crios, one for the competition and one for testing and we program in Java. Today I tried updating out competition crio to the 2014 image over a cable. I managed to successfully update it. When I tried loading our java software onto the crio, it was unable to reconnect after restarting the first of the 2 vms on the robot, I think its called OW, its not the squawk-java one. When I power cycled the robot, it reconnected and then loaded the code onto the robot. Then I went to the driver station to enable to see if the code loaded correctly, the driver station had both the “communications” and “robot code” lights red, but under diagnostics the “robot” light was green. My ip was set to When I had a cable going directly from the robot to the computer, I can ping the robot from the computer but I could not ping the computer using the net console thing they added this year.

The imaging tool said it successfully updated the crio to 2014 v52 image.
The classmate laptop I was using was the 2012 version. We bought it this year and I loaded the correct image onto the classmate a few days ago. The driver station is the most and netbeans pluggins are both the 2014 version.

Does anyone have any idea what could be the problem???

The Diagnostics robot light shows the results of ping. So it agrees with your command line ping in verifying that the cRIO is up and running its TCP stack and has the ip address set correctly.

The Communications light indicates whether the FRC_Communications library is loaded and running. The ni-rt.ini file lists it in the libraries to load, and either it is crashing on load, or the file no longer exists or has been modified. A null-modem serial cable to a terminal program will help determine what is happening during load.

As for the Robot Code light, it indicates that your robot’s code is sending back voltage values. It can’t do that if there is no Communication task running.

I’m confused by the VM comment. It sounds as though you have tried to install your own Java VM on the robot? As much difficulty as Sun/Oracle had getting Squawk to run on VxWorks, I’d say that sounds ambitious. Do you have more details?

Greg McKaskle

Sorry, by other vm I meant the OTA server, I thought I saw vm but I guess I was wrong.

Can you elaborate on the “null-modem serial to a terminal program”??

You will also need to use the imaging tool to enable the serial console. No need to image, just flip the setting and apply.

You can use any terminal program that supports serial communications. PuTTy is nice, but Hyperterminal can do in a pinch.

Greg McKaskle