USB Cam not showing up on one laptop

Hi have a dev laptop and a driver station laptop.

I’m using java and "Smart"dashboard.

The USB camera feed shows up fine on my dev laptop, but gives a connection refused error on the Driver station.

This is with JUST the Driver station running.

The DS can connect to the robot, and my vision processing thread is running, so I know the camera is live, but it just won’t show up on the DS laptop.

We have loaded the latest DS sw (.01), and recently loaded the radio firmware.

Anything we can check on the windows laptop itself?
Firewall is OFF.

Note: This same DS worked fine with video stream last year.

Is it off all three places? Make sure you’re looking at “Windows Firewall with Advanced Security” and not just “Windows Firewall”.

Is there an antivirus/antimalware utility active that might be getting in the way?

We are having the same problem - additional data: If you switch to default dashboard the camera on that one is working - same camera same driverstation just the dashboard that looks like the driverstation. SmartDashboard was working on this driverstation prior to todays update I believe (not 100% positive) Still because the default dashboard works I don’t think its a firewall issue.

If you do Add > Camera Stream Viewer, it should work. If that doesn’t show up, you need to update smart dashboard.

Ok - we fixed the problem on our driverstation. The driverstation doesn’t have the development environment on it so the wpilib tools directory never got updated with this years jar files. I copied my wpilib tools directory from my dev laptop to the driverstation and it seems much happier.

PS smartdashboard now has a mjpg camera and cameraserver options - cameraserver worked for us for this year

experiencing same issue… how do i double check my smartdashboard version?