USB came in corrupt :(

That sounds like a different issue than what I have heard and seen with the E09.

If your E11 Imaging USB shows blank or doesn’t show up at all when plugged into a working Windows machine I would put in a Replacement Parts Request. Make sure (as best you can) that the USB stick is the only part missing or broken before submitting the request, but you have to get it submitted by Wednesday @ 8pm Eastern.

EDIT: Also, make sure you are using the Classmate Imaging USB stick and not the National Instruments USB which is credit card sized.

Looks like I may have stumbled on the root cause… I just tried to make a bootable FreeDOS USB stick (thanks to unetbootin) and then copy the contents of the E09 stick onto my bootable FreeDOS stick. I was unable to copy over the 4.3GB image file, and then it dawned on me, that the E09 stick is an NTFS filesystem and my 16GB stick was formated with FAT32.

My guess is that the E09 Classmate’s BIOS doesn’t know how to access an NTFS filesystem.

Hope I’m not just spreading rumors,
-Jonathan

Same here, but got it to work.

We have the 2009 Classmate, and received the “E09” flash drive.

The Classmate will not boot with the new KOP USB stick (drive error as described above). However it does boot fine with last year’s “2011 re-image flash drive”. So, I used a new 8GB USB flash drive, and Acronis True Image software to make it a duplicate of the “good” 2011 flash drive. I then copy with replace everything from the “un-bootable” 2012 flash drive to the 2011 duplicate flash drive. The new flash drive boots, and runs the 2012 installation.

The problem could also probably be fixed by just fixing the boot block on the bad flash drive.

[FONT=Calibri] [/FONT]
Mike[FONT=‘Times New Roman’]
FRC Team 2619[/FONT]
[FONT=Calibri]The Charge[/FONT]

We also had this problem. Like the others, we had the 2009 classmate and the E09 flash drive. We solved it by copying the files to last year’s flash drive, then using that to image the classmate. We did not use any flash drive imaging software, just windows copy/paste. Though if you have imaging software, using it would probably be a good idea. :wink:

It looks like FIRST is aware of the problem, and posted a temporary workaround for the issue.

Here’s a post from a FIRST forum administrator named Kate:
http://forums.usfirst.org/showthread.php?t=18453

Links to a PDF:
http://www.usfirst.org/sites/default/files/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2012_Assets/ClassmateE09ImagingSuplement.pdf

we had this problem on several classmates during our RQBS. Putting the USB drive in the USB hub, then plugging the hub into the classmate fixed the problem for us.

A Fantastically easy fix they actually updated this recently and if youre running labview you just install the driver station support portion on your classmate and your computer is competition ready

You will need both the new Driver Station Support from the NI USB and the Driver Station Update, but yes it would appear FIRST is saying it is not necessary to re-image to practice or compete.

Comparing the old image to the new, it may be necessary to re-image if you want to use the Kinect as it frees up quite a bit of space you will need for the Kinect software (Visual C# Express is pre-installed on the new image).

:smiley:

Thank you Ben! We had the same issue. The FIRST ‘solution’ seems to deal with NI Labview (I may be mis-reading it but I don’t think so). Tried Ben’s fix and it worked! The only thing to remember is that USB sticks get formatted (at least by default) FAT32 and one of the files is larger than 4GB so when you are copying the files to the new flashdrive make sure to format it NTFS.

For those who are having issues with the National instruments usb, our windows 7 dell laptop did not recognize the drive in any port. But when you pulled up device manger it did list an unidentified USB device. Installing new drivers for that usb port fixed the issue(and yes the laptop recognizes other usb devices).

Team 1895 in Manassas, VA is having the same problem.
2009 classmate, could not boot with USB Drive.
Restarted, used the driver station update.
Now it failed to find some National Instruments software and appears hung.

Really could used some FIRST ORG guidance in this area.

The document detailed by FIRST indicates you have to uninstall all your old NI software, then install the new Driver Station Support Software from the kit NI USB before applying the update.

Team 1849 is also running into this problem.

I see the reference to the kit NI USB in the supplement but we didn’t get one in the KOP and I don’t see one in the KOP inventory. What are we missing?

It’s on the checklist as LabVIEW for FRC. You have to install some components of it even if you don’t program in LabVIEW :rolleyes:

Arggh. Didn’t realize it was in the package that looks like it usually holds disc type media. I feel silly. Looks like we are making progress, but aren’t able to image the machine using the e09 image usb.

We had the one that is white and green, have no idea if it is for the '09 or '11, but what we did was image the flash drive over to a different non-san-disk flashdrive and the image installed great. I imagine we got the '09 image since the team is over 5 years old. The san disk flash drives are weird, so basically duplicate the flash drive on a different flash drive and try from there!

I’ll alert my mentor of this thread and see what he says as he knows more about it than me. No promises on the solution!

After having this same problem (ours is the 2009 Classmate so we received the E09 USB stick in the KoP), we created our own bootable USB stick for the image as described here. The Classmate booted successfully from that and we were able to reimage successfully.

Basically we just copied all the files from the KoP USB stick over to a clean generic USB stick, and then made it bootable using the “bootsect” tool.

(NOTE: “bootsect” is the MS command-line tool to install boot sectors on disks. It can be found on any full versions of the Windows 7 DVD, and is also included in Windows 7 Automated Installer Kit tools which are freely available here.)

Hope this helps…feel free to PM if any questions.

  • Ron
    Team #2607 controls mentor

For those of you on linux all i did was use gparted to toggle the boot flag and ran a check. I don’t know what one made the difference but now the USB is good and I didn’t even have to copy a file.

Hope this helps someone.

Got a more advanced error. After I followed the instructions on usfirst.com to reimage the classmate using a second usb, windows refuses to boot, instead get a BCD error. Wish FIRST would just post the reimaging files to download…

Edit: Got it working after recopying the boot files to the USB. Only problem encountered is having Windows say it is not a valid copy…

The “Getting Started” document linked to from the Kit of Parts Technical Resources page tells you how to activate Windows. It’s in the Initial Driver Station Set Up section on page 8.