USB Camera giving Invalid Image error

My team has been trying to set up camera feedback through the dashboard using Java. I have added the sample code from the Simple Vision example in eclipse.
When I deploy the code to the rio and start up the driver station I get this error.

Error when getting image from the camera: invalid image at pos 56403 (0) at edu.wpi.first.wpilibj.CameraServer.capture( 

This error keeps spamming the log until I disconnect from the rio.
We are using a Logitech C170 web cam. I know that this camera hasn’t officially been tested but it was the only one we had access to. Does this error mean that this camera isn’t compatible?

I used to mentor for Team 1717 and we only used the AXIS network cameras which worked fine in both C/C++ and Java. This year I’m mentoring a rookie team 5818 and we are trying to use the USB Microsoft Lifecam and are encountering this same error and the FPS is only 3-4 fps at 320x240. We noticed a delay of .1 seconds in the Java CameraServer which we reduced but still are unable to achieve a decent frame rate. Please help!

My team used the same camera last year. Our camera code is here:

It might be useful to look at it, let me know if you have questions!