USB Camera Issues

We are trying to view the images on the Dashboard by calling the Java CameraServer class, but we get nothing. Has anyone figured out how to view the images from a USB camera plugged into the roborio or does anyone know if there is a separate program for usb cameras?

(We are using a PS3 Eye camera if that makes a difference.)
Any suggestions?

The java example projects “Simple Vision” and “Intermediate Vision” both show how get an image from a usb camera and how to put it on the driverstation.

We have tried running both of those programs on the roborio with both a user defined name (e.g. “cam0”) and the resource name. We haven’t gotten anything back from either. Both report the supposed camera’s fps, but there is no indication that the camera is being used.

Any ideas to troubleshoot it?

Did you make sure the camera shows up in the web dashboard as cam0? I can’t find anything that says the PS3 Eye is supported by GenICam.

By default it has no name, so we define it as cam0. The name is saved between web sessions, but is lost on shutdown/power cycle.

On our test board mDNS isn’t working, so the USB Camera viewer on the SmartDashboard gave an error that it couldn’t connect to roboRIO-1939.local. We went into the SmartDashboard preferences and disabled mDNS (We set a static ip on the roboRIO). With mDNS disabled the USB Camera worked just fine.

We can connect to the roborio just fine and test the motor controllers and joysticks. I haven’t set up the wireless yet, so we are using usb to connect to the roborio. I’ll set up the router and test if we can view it then.

This thread recommended the ps3 eye and other people seemed to think that it should work.

On the dashboard did you guys change the type of camera to get feedback from?

Yes, we tried all options for camera feedback.

Even though there is no visual and the camera’s indicator light is off, the dashboard still displays an fps. Should it?

Can you try another camera? The PS3 Eye may not be support natively by the roboRio.

I had posted in that thread that the PS3 eye works on the beaglebone and Jetson TK1. For the Jetson board I had to compile & install a kernel module before I could get it working. I suspect the same may be true for the roboRIO, though I have not begun to investigate.

The easiest route would probably be to use the HD3000 since this is what was developed & tested on. Is there a specific need to use a cheaper camera as the OP of the thread you linked had wanted?

I believe the PS3 Eye camera is support by Video4Linux. It should be possible to install that and use it on the roboRio, correct? That should allow access to the Eye camera.

When I had posted this question I was under the impression that the other programmers had installed the appropriate drivers when I was away. That wasn’t the case, so we are now using a new camera.

For any teams looking to use a PS3 Eye camera, you will need to use the gspca-ov534 ARM drivers. It seems to require make to install(which the roborio doesn’t have), so you will have to manually download and extract the drivers for roborio install. It isn’t worth it imo, but if that’s your only option, start your search with gspca-ov534.