USB camera not displaying to dashboard

Our microsoft USB camera isn’t displaying to our dashboard. We now have the default vision processing code and we still aren’t getting anything. The selection for the camera is on the dashboard, but whenever it is selected, the space where the image should be still says “no camera selection”

There have been other threads on this topic. Check the variables tab on the dash and go to where the camera ip address is displayed. If it is missing “.local” in it, that may be your problem. You will have to modify Send2PC vi (for LabVIEW) to concatenate the .local on.

Possibly the port is being blocked.

Does anyone know how to change the MPEG port on a Labview program? Both on the Labview/roboRIO side and the dashboard?

Make sure the frame rate, compression, and image size are set relatively low.

FIRST has identified a couple issues with LabVIEW team’s USB cameras feeding back to the Dashboard. For those having this issue currently at an event, talk with a CSA (they are volunteers with orange Control System Advisor caps). Otherwise, watch out for the team update on Tuesday.

EDIT: By identified I just mean they are working on it.

Our team faced a similar problem not too long ago.

Make sure under your Robot Main.vi, you have enabled vision. If you open the VI, click the green button.

If that causes the camera to appear under the drop down, but not appear when you select it, you are halfway there. Ether press the “Restart Robot Code” button on the dashboard, or press the reset button on the robo-rio. If your code is on the robot, it should display the camera after turning back on.