USB ports on roboRIO not recieving power

We are trying to use the Microsoft hd-3000 camera and the roboRIO isn’t recognizing the USB ports or giving them power. We’ve tried using LSUSB in the terminal to activate them, but it says it isn’t a recognizable command.

Please verify that the camera function correctly when plugged into a laptop or other computer. Then try each of the roboRIO ports to verify that the LEDs of the camera turn on, at least initially. If they do not, please try a different USB device to see if that receives power.

I no longer have that camera, but have used it in the past, and it worked fine for me. In case there are newer revs, can you post details of the camera such as model and serial number?

Greg McKaskle

We already tested the port for power with a phone charger and it wasn’t receiving power. We also tried plugging it into the computer and it worked just fine. But we were using last year’s robot to test the drive code and camera so we decided just to not worry about it until the build team is done with the new robot.