Using versus confidence


I have read all the related posts and I still have some confusion.
We have been using
if ( != 0 )
to determine if the camera sees the target light and it was working perfectly.
everyone says to use
if (T_Packet_Data.confidence > ##)
which was not working… but may be we have not found the right confidence.
I don’t understand why != 0 worked so well and what I should be worried about if I keep using that.
May be should I use something like…
if ( != 0 && T_Packet_Data.confidence > 80)

Our camera is not working at all since we shipped this years 'bot and mounted on the 2005 system. We recompiled for the 8520 board without problems using Using_Last_Years_FRC.txt.

The camera has both the red and green lights on like it’s got the target even if we cover the lense. I read all the posts and so far no luck…
We connected to Labview and the camera lense is grabbing frames without problems. We connected the camera pwms to a joystick and the pwms work.

Any more thoughts on this?



The .mx and .my values can/will be non-zero when there is no green light in view. We verified this in our shop. The .confidence value appears to find green light correctly most of the time. We found it did not work well in the pit area at our Regional. Neither method is foolproof. The new default camera code uses a confidence threshold of 20.

Check the state of your camera using the terminal output. We constantly encountered problems where the camera software would not initialize and was unusable in every match. The best we could determine was it would fail if the reset button was pressed in autonomous mode. It always worked fine during testing in user mode.

We figured out the SECOND part of the post.
Our noise filter was zero and it should be one.
I have no idea when that was changed.

Any comments on the FIRST part of the post?
I’m nervous keeping the code how we have it, but it works so well…


OK. No we didn’t figure out the SECOND part of the post.
Our camera is stuck.
We are now thinking that it is the TTL that is broken on the 2005 controller.
We are connecting to the 2004 controller.
We’ll see.
Any help would be appreciated. Red and Green lights stay on on the camera and it is frozen…
No searching… .coming into COM1 (no surprise there)

Try holding the RC Reset button for at least FOUR seconds. When our camera freezes like that, this is the remedy that works.

We encoutered the same problem as your second part. All the lights were on and the camera wasn’t tracking at all. It turns out our camera was damaged during shipping or something because we replaced the lense part of the camera and it was up and running perfectly again. Just a suggestion, hope it helps. The camera has been a nightmare for me, I’m the rookie programmer and leader of our programming, lol!

EDIT: And yes, if the camera stops working, I usually have to HOLD the reset button, not simply press it. Don’t know why it does that, but it solves all problems!

My teams camera was broken when it came falling down from 60 inches. We had to replace it with a 2005 lens, and it worked perfectly again. The lens really is too sensitive.

Turns out our TTL connector on the processor was broken.
We used the 2004 robot which is the same as the 2005 and it works.