v11 cRIO Image Error

After downloading the Labview 3 update and the Windriver 3 update, I proceeded to re-image the cRIO with the v11 image. After making connection with the cRIO, I then selected the appropriate preferences and began to re-image it. After sitting there for a bit, it gave me this error:

Unable to assign an IP address for the CompactRIO device. Ensure the IP Reset switch on the CompactRIO device is turned off.

The IP Reset switch is indeed off, but just to make sure, I flipped it in the “on” position and tried it again. Still nothing. Anyone got any ideas?

Thanks!

Just tried it again under the same settings, I got this error:

Unable to complete operation because of unexpected error 56:
UDP Read in repFPC read packet.vi->Get Target Info (MAC).vi->Format Target.vi->ConfigUtility.lvlib:ReImageTarget.vi->ConfigUtility.lvlib:Dialog.vi

I’m formatting for WindRiver by the way.

Edit

After restarting my computer and opening the cRIO Imaging Tool again, I find the cRIO no problem but with the name as “temp” and the IP of 0.0.0.0. I don’t really have a good feeling about that…

The cRIO IP gets set to 0.0.0.0 briefly during the imaging process.
The IP reset also will set it to 0.0.0.0

The FRC imaging tool can talk to it, although some PCs have trouble with IP addresses of 0.0.0.0

You don’t still have the IP Reset on do you? That must be off.

Try re-imaging again.

This time, make sure you do a full power down of the cRio. a reset is not enough, because the FPGA needs a power-on-reset.

Yep, I tried a full power down and made sure the reset switch is off. I’m still getting the “IP Adress error make sure your IP Reset switch is off” deal.

Currently, my cRIO’s name is “temp” and it’s IP is 0.0.0.0…and its not letting me image the v11 image.

Edit

After aquiring a mind of its own, the cRIO has suddenly come up with the IP 10.17.10.2 (1710 is our team name). The name is still temp. My static IP is set to 10.17.10.2 with a subnet of 255.0.0.0. I’m now getting this error with the imager:

The specified IP address is unreachable. Ensure that the IP address is on the correct subnet.

The specified subnet for use according to section 5.1.2.3 in the manual says “255.0.0.0” soooo is should be working. Unfortunately its not. Any ideas?

Your PC’s static IP address should be 10.17.10.6 (not .2, because that’s the cRIO’s address).

Correct, it is.

Fixed the problem. Thanks

we also had the same error as described above. however, we fixed it by using the measurement and automation explorer tool (MAX)

  1. Reboot the controller into Safe Mode by flipping the Safe Mode DIP switch to ON and cycling the power by pressing the Reset button on the controller and holding it down for about 10 seconds. After recycling power the Power LED should then be lit.
  2. Open Measurement & Automation Explorer (MAX) by navigating to Start»All Programs»National Instruments»Measurement & Automation.
  3. Expand Remote Systems by clicking on the + as seen below.
    Click on your Real-Time hardware under Remote Systems, click on the Network Settings tab, and verify that the System State is Connected - Safe Mode (User Directed). If it says “uninitialized” then you need to type in a name and IP address in the fields.
  4. Right-click on the Real-Time hardware and select Format Disk.
    Select Yes when MAX asks you if you would like to continue.
    Important Flip the Safe Mode DIP switch back to OFF. Be sure to follow this step as the controller will reboot in safe mode on the ROM chip if you do not flip the DIP switch.
  5. Click on the OK button in the window from MAX indicating that formatting was successful. Immediately after you click on OK, the RT hardware reboots.
  6. Go to the FRC cRIO Imaging Tool on your desktop and deploy the image to the cRIO