V3 Color Sensor from Rev Robotics

What is the trick in getting these libraries recognized? I have installed from the RevRobotics site, moved the .json file to dependencies, etc… What am I missing?

import com.revrobotics.ColorMatch;

import com.revrobotics.ColorMatchResult;

import com.revrobotics.ColorSensorV3;

import edu.wpi.first.wpilibj.util.Color;

If you put the vendor file there yourself, you may need to run a build.

Open the WPILib dialog and run the build robot code option.

If you install the library via the manage vendor libraries option, it prompts you to do this.

Performed the build per your suggestion - no change, it does not recognize the import.

Silly question, have you tried closing and re opening VSCode and letting it sit for a minute or so. I had the same problem last night and this fixed it.

Had this issue as well. Download the SDK, copy/paste it into the wpilib folder in the public user’s wpilib/maven/com folder, then it might work. Maybe someone can link the relevant thread

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.