Various Issues Loading Firmware onto Radio

I’ve started to lose my sanity here…

Our radio has been the single greatest roadblock in this practice build so far. Our radio refuses to cooperate when using the 2020 FRC Radio Configuration Utility. None of the 4 computers we have attempted to configure the radio with so far have shown the mystical “Local Area Connection __” that the WPILib shows in their images. Proceeding on using the “Ethernet” option in the vague hope that it would still work, the radio shows an error when attempting to use the “Load Firmware” button. Below is a list of other troubleshooting steps we have taken, along with any noticeable change as a result if present.

  • Disabling every network device except for the ethernet device we intend to use. This resulted in no “Local Area Connection”, but did however result on a new error when hitting the “Load Firmware” button, stating something about an NPT device with the name of our ethernet card not being found.
  • Running the AP51-Flash utility via command line, both on Windows and Linux. Windows resulted in the utility stating that it was verifying the path of the firmware file, then hanging indefinitely with no more output. Linux would not show the ethernet device in the list of compatible devices.
  • Using the 2017 version of the utility. This got us the closest we’ve ever gotten; the utility hung on instructions to turn the router off and on again, where it later timed out despite our powercycling the router.
  • Assigning our laptop a static IP. IPs we tried (both Linux, Windows) include: 192.168.1.51, 192.168.1.10, 192.168.1.11, 10.54.11.10, 10.54.11.1. An attempt to ping IPs 192.168.1.1 and 10.54.11.1 was made on all static IPs we tried. Only deviation was on IPs 10.54.11.1 and 192.168.1.1, until we realized we were getting pings from ourself. All other IPs gave “Destination host unreachable”
  • Swapping the radio. We only had one radio to swap with, but similar things happens.

Has anyone been in a similar situation?

1 Like

This issue comes up pretty frequently. Also, turning the radio off and on again, it takes a long time for the radio to come back. Try the procedure at the link, it will at least eliminate a frequent known issue.

We got our radio issues solved. Unfortunately, using the version of Java specified in the article you listed had not resolved the issue.

Our issue was the PoE injector. Connecting the Radio directly to power and using an Ethernet cable going directly from radio → computer allowed us to configure and flash firmware with no issues.

2 Likes

Mind marking this as a solution? :slightly_smiling_face:

Sorry, I’m still new to the site. Marked as solution.

1 Like

Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.