Very Strange cRIO Crash

*I am currently trying to make a class, based loosely on the dashboard data demo program, to abstract both the robot’s hardware and its connection to dashboard. Right now the class initializes all the hardware (except PWMS, which it waits for the robot to request one of the type it needs) including the camera in its constructor. Whenever I run my update method to send the information to dashboard however, it crashes. After a few days of debugging I can’t seem to determine exactly what is causing the crash but I do know things that specifically do and do not cause a crash: If I leave the update method as intended, it crashes as soon as the first dashboard method is called, however, if I comment out ALL dashboard related code, it still crashes but simply a semi-regular period of time afterward (I get a different amount of my printfs back every time I crash it in the way). If I remove the printfs (or most of them) it runs fine! Also, if I initialize the dashboard and ONLY use finalize methods (finalizeCluster and just finalize) it runs, but spouts errors about miss-matched add and finalize calls (makes sense). The interesting this is the crash occurs in FRC_RobotTask but only one stack is present. The assembly in the area it crashes is a VERY long string of “.long 0” (over and over for as far as I can scroll up) and occurs exactly at address 300 every time.

If you want to take a look at the code you can find it here:

The method that crashes is HardwareInterface::UpdateDashboard and currently it only has the printf commented out.

ANy help would be GREATLY appreciated, I’m really at a loss here.*

EDIT : Fixed it! was accidently overwriting the bounds of a few arrays, with disastrous results.