Need some help with our VEX bot. We have had a few veterans look at this bot, and we are all puzzled.

When we try to drive the bot, it only works for a few seconds, and then it slows down until it isn’t moving at all. Although, once we wait a few seconds without holding any of the controls, it works fine.

We have tried some troubleshooting; replaced the batteries(possible that they may be going bad) we tried it tethered(still had the problem). We for sure have enough power (using normal vex motors, 2 motors per side. Only geared slightly for speed).

If anyone could help with this problem, it would be much appreciated.

Binding in the drive train?

Waiting could allow deformed parts to return to their proper shapes letting you drive again.

I don’t know this for sure, but it’s worth looking into.

Your drive motors are probably drawing too much current. Adjust the gear ratio for more torque.

Some more information about the dt(gear ratio) the weight of the robot, the programming language, the type of microcontroller being used, the type of communication system being used can be very helpful.

In the meantime I think Chris’s suggestion seems the one that pops up the fastest, but slightly geared for speed, (s:m or m:b) will not necessarily cause this to happen.

  • Sunny

I’d also go with too much current. Your FRC robot would probably act the same way if the breakers were tripping, though with a bunch of audible snaps.

Quick test: Pick the robot up off the floor. Run it. If it keeps going, you should re-gear–you’re drawing a lot of current when it’s on the floor. If it exhibits the same behavior when it’s off the ground, check for binding or debris in the drivetrain. If everything is clear, check code.

It could also be that the motors are trying to fight each other, though that would be more likely to stop the robot altogether.

I don’t think it’s communication; tethering and wireless are both bad. I also don’t think it’s binding; while that could be an issue, it would be most likely to happen at the same place every time.

Also what you can try is opening up the VEX motor and make sure there is nothing in the gearing inside the motor i.e. hair or the like. We had a similar problem and it turned out to be one of the girls hair got caught in the motor and prevented it from moving on the ground but not while being held in the air. Also remember that the VEX motors are mini gear boxes check those workings often you might have snapped something.

VEX controllers have an internal PTC type of circuit breaker. You did not mention in your post if the lights on the controller were dimming or if the controller was rebooting but I am guessing that is the problem. Most likely cause is a binding drive train. You must use the bearing plates for all shafts. You might also have misaligned gears such that there is too much friction between gears. The gears should be able to move slightly with your finger and light pressure. You may also have a bad motor(s). Does the robot run OK when you lift it up so the wheels are not touching anything?

This happened with mine, I have a 2 stage telescoping arm on linear slides, and the bottom slides worked fine but when the top slide extended they would go up and a very slow pace. It turned out that we had our axle tensioned to much and it bent. Try direct drive and if that doesn’t work Like Chris said, your probably drawing to much current, but are you running on the 7.2v battery’s or the 9.6’s? If you are running one the 9.6’s try the 7.2’s.

s:m is actually a pretty large overgear (1:3). That you can generally only get away with with a light robot using small wheels.