Victor 884 issue

To start with, we haven’t used Victors for a few years… our competition robot was done entirely with Talons.

A couple of our students are working on a separate project, using a couple of old Victor 884’s. We’re getting some odd behavior from them, though… We can power them full reverse and stop, but we get no output if we try to go forward or use an other values. It’s programmed with the Victor class.

Tonight, we tried swapping out one of the Victors for a Jaguar, with the only code change being to change the class from Victor to Jaguar… with that, we got full range of motion as expected.

We’ve quadruple-checked all the wiring, and it all looks like we expect. We’ve swapped the Victors for other Victors and get the same results.

Does anyone have any idea what could be causing this, or how to fix it?

That’s strange. What light patterns do you see on the status LED when you’re commanding the motor controller, but not seeing any motion?

Did you try to calibrate the victors?
See calibration instructions on page 2:

If they were never calibrated before you shouldn’t have had to do this. But it’s something easy to check.

  1. check to make sure your DSC is getting power. All lights fully lit.

  2. are you using any PWM Y-cables?

We’ve never calibrated any of them before, but I did mention that to the students (I was advising them remotely)… I’ll make sure they do it when they meet tomorrow, just to make sure.

I’ll have them double check the DSC power. Last time I saw the setup, it was fully powered… we have moved build spaces since then, maybe something came loose during the move!

There are no PWM Y-cables in use. They even tried swapping PWM cables (I think they said they went through 3 different cables).

Any other ideas? One thing the did mention was that they had issues with the Victor 888 in the fall, but that it seemed to work fine now. They were wondering if there might have been a code update that made the 888 work better, but caused issues with the 884?

missed this question… the LED is off. No blinking, no color, nothing.